― MozillaZine.jp フォーラムは Mozilla 製品に関する情報交換の場です ―



All times are UTC + 9 hours

新しいトピックを投稿する トピックへ返信する  [ 16 件の記事 ]  ページ移動 1, 2  次へ
作成者 メッセージ
投稿記事Posted: 2008年3月06日(木) 19:49 
TBの添付ファイルについて
http://forums.mozillazine.jp/viewtopic.php?t=2364
の同様質問です。

先日来(GmailのIMAP受信を利用するようになってから)上記トピックと同様な症状で悩んでいます。

症状は、日本語の添付ファイル名が「Part 1.2」「Part 1.3」などに変わり、拡張子がなくなります。
拡張子を正規のものに変えると内容は正常に開けます。
(試験的に自分で送ったファイルは拡張子が分かるので、、)
拡張子別では、.doc .xls .pdf .jpg など、ほとんどがおかしくなります。
.txt だけはなぜか正常です。
pop受信の場合は全て正常に受信できます。

環境は下記です。
Thunderbird 2.0.0.12(Portable版)にてGMailをIMAPで利用しています。
OS は WinXp Home sp2
拡張はSignature Editor 1.2、Locale Switcher1.2、GMail Acount IMAP Setup 1.3.20、Get befor Send 0.7.20

以前(v 1.5)の頃にも日本語添付ファイル名が変わる不具合があり、下記アドレスの説明を読み、「mail.strictly_mime.parm_folding」を「0」にして対処できました。
当時、Hotmail 宛の添付ファイルがファイル名がおかしいと言われ検索してヒットした内容でした。
その時はそれで解決しました。

受取人のメールクライアントによって、添付ファイル名が正しく表示されない場合がある
http://www.mozilla-japan.org/kb/solution/3067

v 2.0 になり「mail.strictly_mime.parm_folding」のデフォルトが「2」から「3」に変わっていたので、Hotmail へはテストしてみたところ、「3」のままで正常に送れる事が判明し、「3」のまま使っていました。
今回、再び「0」に変更してみましたが改善されませんでした。
メールをソース表示して「MIME ヘッダ」なるものを見てみたのですが正常と異常の判別はつきませんでした。

異常なもの(ファイル名は、あい、あいう、あいうえお、です)

--b07bd5910730f0d09803b9e81d64c0f01
Content-Type: application/vnd.ms-excel; name="=?ISO-2022-JP?B?GyRCJCIkJBsoQi54bHM=?="
Content-Transfer-Encoding: base64

--b07bd5910730f0d09803b9e81d64c0f01
Content-Type: application/msword; name="=?ISO-2022-JP?B?GyRCJCIkJCQmGyhCLmRvYw==?="
Content-Transfer-Encoding: base64

--b07bd5910730f0d09803b9e81d64c0f01
Content-Type: application/pdf; name="=?ISO-2022-JP?B?GyRCJCIkJCQmJCgkKhsoQi5wZGY=?="
Content-Transfer-Encoding: base64

正常なもの(ファイル名は、a、2、1、です)

--be25631892f51f14c8a8dc53b746c8285
Content-Type: application/vnd.ms-excel; name="=?ISO-2022-JP?B?YS54bHM=?="
Content-Transfer-Encoding: base64

--be25631892f51f14c8a8dc53b746c8285
Content-Type: application/msword; name="=?ISO-2022-JP?B?Mi5kb2M=?="
Content-Transfer-Encoding: base64

--be25631892f51f14c8a8dc53b746c8285
Content-Type: application/pdf; name="=?ISO-2022-JP?B?MS5wZGY=?="
Content-Transfer-Encoding: base64

上記関連トピックのhogehogeさんと同じように異常なメールを転送をかけると添付ファイル欄には正常に表示されます。
アイコンも正常です。そこから開くと正常に開けます。

どなたか原因と対処法をご存知の方がいらっしゃいましたらご教示ください。


# Mozilla Thunderbird, Portable Edition の話題ですので「Mozilla Thundebird」
  フォーラムから「その他」フォーラムにトピックを移動しました。
  by 管理人 Premier


通報する
ページトップ
  
引用付きで返信する  
投稿記事Posted: 2008年3月06日(木) 20:46 
オフライン

登録日時: 2005年6月21日(火) 05:07
記事: 1617
お住まい: Kyoto,Japan
下記トピックは参照されましたか?
ML上にて、自分のメールに添付ファイルがついているように表示されます(Part1.2)

引用:
関連しそうな原因としては、Microsoft Outlook の TNEF(Transport
Neutral Encapsulation Format) か、AVG (an anti-virus program)
がありそうですね。

IMAP のポートで AVG が悪さをしているとか?
セーフモードや新規プロファイルの適用でも再現しますか?


通報する
ページトップ
 プロフィール  
引用付きで返信する  
投稿記事Posted: 2008年3月07日(金) 20:44 
返信ありがとうございます。

>下記トピックは参照されましたか?
>ML上にて、自分のメールに添付ファイルがついているように表示されます(Part1.2)
はい、そのトピックも読んだのですが、
セキュリティソフトはAvira AntiVir PersonalEdition Classic を利用しており、AVGは利用していません。
Microsoft Outlook は未インストールです。
従って少し違うかなと思いました。

>セーフモードや新規プロファイルの適用でも再現しますか?
Thunderbird, Portable Edition 2.0.0.12 を利用しているため、セーフモードは出来ないと思います。
http://portableapps.com/news/2008-02-27 ... e_2.0.0.12
一応全ての拡張を無効にしてやってみましたが、状況は変わりませんでした。

新規プロファイルの適用は具体的に良く分からないため、改めてダウンロードしに別フォルダにインストールし、GMail Acount IMAP Setup 1.3.20 のみをインストール後に同期をとってみましたが、結果は同じでした。

他にやってみることがありますでしょうか。
よろしくお願いいたします。


通報する
ページトップ
  
引用付きで返信する  
投稿記事Posted: 2008年3月07日(金) 22:02 
オフライン

登録日時: 2005年6月21日(火) 05:07
記事: 1617
お住まい: Kyoto,Japan
zizi さんが書きました:
はい、そのトピックも読んだのですが、
セキュリティソフトはAvira AntiVir PersonalEdition Classic を利用しており、AVGは利用していません。
Microsoft Outlook は未インストールです。
従って少し違うかなと思いました。

であれば最初にその旨を書いてください。

zizi さんが書きました:
Thunderbird, Portable Edition 2.0.0.12 を利用しているため、セーフモードは出来ないと思います。

以下のサポートフォーラムのスレッドによると Firefox の場合ですができるようです。
当方ではセーフモードで起動しました。
NO SAFE MODE! | PortableApps.com - Portable software for USB drives
John T. Haller さんが書きました:
Just execute from the command line:
FirefoxPortable.exe -safe-mode


zizi さんが書きました:
新規プロファイルの適用は具体的に良く分からないため、改めてダウンロードしに別フォルダにインストールし、GMail Acount IMAP Setup 1.3.20 のみをインストール後に同期をとってみましたが、結果は同じでした。

GMail Acount IMAP Setup ってひょっとして Gmail IMAP Account Setup のことですか?
もしそうならばバージョンが古いですね。
また Thunderbird, Portable Edition に対応しているか確認されていますか?

zizi さんが書きました:
他にやってみることがありますでしょうか。

もし私が同様のケースに遭遇したら以下のことを試してみると思います。
・Thunderbird, Portable Edition をセーフモードで起動。
・Thunderbird, Portable Edition に新規プロファイルを作って適用。
・新たに USB メモリに Thunderbird, Portable Edition インストールして新たに Gmail IMAP
 アカウントを手動で設定してみる。
・mimeTypes.rdf を削除して再起動してみる。
・自分宛に各種添付ファイル付きメッセージを送受信してみて Web 上のメッセージとの相違点を
 確認する。
・セキュリティ関連のアプリケーションを疑い、無効化またはアンインストールしてみる。
・PC 本体にインストールしてある Thunderbird でもテストしてみて相違点を探る。
注:mail.strictly_mime.parm_folding はデフォルトのまま変更しない。


# Mozilla Thunderbird, Portable Edition の話題ですので「Mozilla Thundebird」
  フォーラムから「その他」フォーラムにトピックを移動しました。
  by 管理人 Premier


通報する
ページトップ
 プロフィール  
引用付きで返信する  
投稿記事Posted: 2008年3月07日(金) 22:04 
オフライン
Administrator

登録日時: 2005年7月23日(土) 16:55
記事: 1297
zizi さんが書きました:
Thunderbird, Portable Edition 2.0.0.12 を利用しているため、セーフモードは出来ないと思います。

出来ますよ。
以下トピにセーフモード起動の解説ありますので参照して下さい。
mozillaZine 日本語版 :: 参考トピック - Thunderbird portable起動時のエラー


通報する
ページトップ
 プロフィール  
引用付きで返信する  
投稿記事Posted: 2008年3月08日(土) 20:03 
Premier さん、POCH さん、ありがとうございます。
>以下のサポートフォーラムのスレッドによると Firefox の場合ですができるようです。
>以下トピにセーフモード起動の解説ありますので参照して下さい。
確認し、セーフモードでの実行ができました。
しかし状況は改善しませんでした。
>GMail Acount IMAP Setup ってひょっとして Gmail IMAP Account Setup のことですか?
失礼しました、ご指摘の通りです。
ただ、改めてダウンロードし、別フォルダにインストールしたThunderbird, Portable Edition に入れた拡張はバージョンは1.4.20 の最新版でした。
しかし改善しませんでした。
再度 Thunderbird, Portable Edition をダウンロード、インストールし手動にて IMAPアカウントの設定をしてみましたが改善されませんでした。
>また Thunderbird, Portable Edition に対応しているか確認されていますか?
作者の方への確認はしていません。
自分で使ってみて同期できたので勝手にOKと思い込んでました。
「正常に同期(ファイル名も含み)」出来て、はじめてOKなんですね。
>mimeTypes.rdf を削除して再起動してみる。
mimeTypes.rdf は2つありましたので両方ともゴミ箱に移動し、再起動してみましたが改善されませんでした。
>セキュリティ関連のアプリケーションを疑い、無効化またはアンインストールしてみる。
Avira AntiVir PersonalEdition Classic を無効化してみましたが改善されませんでした。
>PC 本体にインストールしてある Thunderbird でもテストしてみて相違点を探る。
元々Thunderbird, Portable Edition をPC本体で使用しています。
試験的に Thunderbird(Portable ではないもの) をインストールし、手動で IMAP の設定をし、同期させてみましたが状況は同じでした。
>自分宛に各種添付ファイル付きメッセージを送受信してみて Web 上のメッセージとの相違点を確認する。
ブラウザ上では全て正常に表示されます。
いろいろやってみてかなり混乱してきました。
1)ブラウザ上から送信し、IMAP 受信したメールは全て(goo、yahoo、プロバイダーメール、Gmail) NG でした。
2)Thunderbird, Portable Edition からGmail、yahoo 経由で送信し、IMAP 受信したものはファイル名、拡張子は正常に表示される事がわかりました。
しかし、アイコンが正規のものになりません。
3)他のメーラー(nPOPQ)での送信も試してみましたが、ファイル名、拡張子は正常ですがアイコンが異常でした。(2 と同じ状況です)
1)、2)の場合、転送をかけると添付ファイル欄には正常な状態で表示されますが、3)の場合は転送をかけても添付ファイル欄はアイコンだけが異常のままです。

こんな状況です。


通報する
ページトップ
  
引用付きで返信する  
投稿記事Posted: 2008年3月08日(土) 23:36 
オフライン

登録日時: 2005年6月21日(火) 05:07
記事: 1617
お住まい: Kyoto,Japan
具体的に確認されたレポートありがとうございました。

zizi さんが書きました:
2)Thunderbird, Portable Edition からGmail、yahoo 経由で送信し、IMAP 受信したものはファイル名、拡張子は正常に表示される事がわかりました。
しかし、アイコンが正規のものになりません。

当初の問題の一部は解決したということですね。

zizi さんが書きました:
1)ブラウザ上から送信し、IMAP 受信したメールは全て(goo、yahoo、プロバイダーメール、Gmail) NG でした。

どういうことなのかよくわかりません。
Gmail でブラウザ上から添付ファイル付きのメッセージを goo、yahoo、プロバイダーメール、Gmail
などの自分宛のアカウントに送信してそれを Thunderbird, Portable Edition で Gmail の IMAP
で同期受信した場合ですか?Gmail へ転送設定してるのでしょうか?
それとも POP 受信した場合でしょうか?
NG とは具体的にどういう状況になるのですか?

zizi さんが書きました:
1)、2)の場合、転送をかけると添付ファイル欄には正常な状態で表示されますが、3)の場合は転送をかけても添付ファイル欄はアイコンだけが異常のままです。

残る問題はアイコンが関連付けされているアプリケーションのものと異なるということですね。
拡張子に対する関連付けが OS 上でうまくできていないように見受けます。
何かしらのアプリケーションが拡張子(ファイル)の関連付けを変更している、壊している、レジストリの
異常などの要因が関係しているのかも知れません。


通報する
ページトップ
 プロフィール  
引用付きで返信する  
投稿記事Posted: 2008年3月09日(日) 09:26 
Premier さん、ありがとうございます。

>当初の問題の一部は解決したということですね。
いいえ、そうではありません。
当初は goo からブラウザ上で Gmail へ送信し、Thunderbird, Portable Edition で IMAP 受信のみしていました。
そのやり方では全て「Part 1.2」となり、拡張子がなくなります。
今回は goo だけでなく、yahoo、Gmail の別アカウント、プロバイダーメール(Webメール的な利用が出来ます)からもブラウザ上で送信してみました。
すると、goo の時と同様に「Part 1.2」となり拡張子もなくなり NG であったと言うことです。

>どういうことなのかよくわかりません。
今回は更に、yahoo、Gmail へは POP アクセスが出来るので Thunderbird, Portable Edition の yahooアカウント、Gmail 別アカウントから Gmail 本アカウントへ送信してみました。
そして Gmail の IMAP で同期受信しました。
すると今までの不具合とは違い、ファイル名、拡張子は正常でアイコンのみが関連付けのないアイコンになりました。

次にメーラーを変更したらどうなるかと思い、nPOP を使い yahoo への POPアクセスを利用し、Gmail 本アカウントへ送信し、Gmail の IMAP 同期受信を試しました。
すると Thunderbird, Portable Edition の時と同じで、ファイル名、拡張子は正常でアイコンのみが異常になりました。

伝え方がまずくてすみません。
一部が解決したのではなく、別の送信方法を試したら、不具合の状況が変わったということです。
転送をかけた場合の添付ファイル欄の表示も、ブラウザ上で送信し IMAP 受信したものと、メールソフトから送信し IMAP 受信したものでは違う結果になったということです。


通報する
ページトップ
  
引用付きで返信する  
投稿記事Posted: 2008年3月13日(木) 07:58 
同じ症状で困っていたので、書き込みます。
僕の場合は、「このフォルダをオフラインで使用する」(フォルダを右クリック→プロパティ→オフライン)にチェックを入れ、今すぐダウンロードで受信したあと、添付が日本語ファイル名に戻りました。


通報する
ページトップ
  
引用付きで返信する  
投稿記事Posted: 2008年3月13日(木) 13:13 
私も同じ事象でここ半月ほど困っていました。
Gamekozoさんと同じですが、私の場合は、「ツール」→「アカウント設定」→「オフラインとディスク領域」の「オフライン」で「受信トレイのメッセージをオフラインでも読めるようにする」にチェックを入れ、ダウンロードが完了したら、添付が日本語ファイル名に戻りました。


Gamekozo さんが書きました:
同じ症状で困っていたので、書き込みます。
僕の場合は、「このフォルダをオフラインで使用する」(フォルダを右クリック→プロパティ→オフライン)にチェックを入れ、今すぐダウンロードで受信したあと、添付が日本語ファイル名に戻りました。


通報する
ページトップ
  
引用付きで返信する  
投稿記事Posted: 2008年3月13日(木) 20:05 
Gamekozo さん、K_DH さんありがとうございます。
教えていただいた方法で、正常に表示されることが分かりました。
ただ、そういった方法だと POP 受信と機能的に変わらないように思うのですが、、。
IMAP 同期受信はメーラーを立ち上げると同時に同期するところがミソと勝手に思い込んでます。
メールをローカルに保存せず、メーラーの起動でサーバーと同期させ、メールが確認できるところが良いところなのではないでしょうか。

その後、試験的にOutlook Express、Eclair、QMAIL3 などで IMAP受信してみましたが、全て正常に表示されました。
どうも Thunderbird 特有の問題のような気がします。
修正されるのを待ちたいと思います。

皆様、ありがとうございました。


通報する
ページトップ
  
引用付きで返信する  
投稿記事Posted: 2008年3月18日(火) 21:29 
>皆様、ありがとうございました。
等と言いつつ、まだ試行しています。

その後、sylpheed、Windows Live Mail でも正常に表示されることを確認しました。
併せて、Thunderbird, Portable Edition でも正常に表示されるファイルがあることが分かりました。
調べた結果、画像が挿入されているファイル(word,excel)では異常となるようです。
テキストだけの場合は正常に表示されます。
以前に書いた 「.txt は正常表示」と関連がありそうです。

p.s.
Google へも報告をしたのですが、Thunderbird サイドの問題のように思えるので、どんな結果になるか分かりません。連携して解決されると、とてもうれしく思います。


通報する
ページトップ
  
引用付きで返信する  
投稿記事Posted: 2008年4月01日(火) 23:08 
はじめまして。
Gmail IMAP Account Setup を作っている者です。

私のところでも再現しました。
で、いろいろ試してみたところ、どうやら
mail.server.default.mime_parts_on_demand を false に設定すると直るようです。
試してみてはどうでしょうか?

しばらく様子をみて、問題がなければ、 Gmail IMAP Account Setup で自動的に設定するように
しようと考えています。


通報する
ページトップ
  
引用付きで返信する  
投稿記事Posted: 2008年4月02日(水) 08:41 
h.ogi さん、はじめまして。
また、ありがとうございます。

>mail.server.default.mime_parts_on_demand を false に設定すると直るようです。

先ほど早速に試してみました。
改善されました!!

このトピックの閲覧者数を見ても多くの方が関心を持たれているようです。
皆さんも改善できると良いですね。

IMAP の設定は少しとっつきにくい部分がありますが、Gmail IMAP Account Setup をみつけ、挑戦してみました。
重ねてお礼申し上げます。
ありがとうございました!!


通報する
ページトップ
  
引用付きで返信する  
投稿記事Posted: 2008年4月02日(水) 21:42 
お役に立ててなによりです。

詳しく調べてみたのですが(詳しく調べずに投稿しちゃってるのも問題ですが…)、
Mail and news settingsによると、
引用:
True (default): Fetch the minimum portion of the message needed.
False: Fetch the entire message, including attachments regardless of whether they're needed.

とのことで、添付ファイルを開く必要があってもなくても、メッセージを開くたびに、
メッセージ全体をとってくるようになるそうです。
なので、添付ファイルが大きいと、パフォーマンスが大きく低下しそうです。

お知らせした、
 mail.server.default.mime_parts_on_demand
では、すべてのIMAPサーバの設定を変えてしまうので、
 mail.server.server1.mime_parts_on_demand
のように、サーバごとに設定したほうがよさそうです。
#server1 はご自身の環境に合わせてかえてください。


通報する
ページトップ
  
引用付きで返信する  
期間内表示:  ソート  
新しいトピックを投稿する トピックへ返信する  [ 16 件の記事 ]  ページ移動 1, 2  次へ

All times are UTC + 9 hours


オンラインデータ

このフォーラムを閲覧中のユーザー: なし & ゲスト[0人]


トピック投稿:  可
返信投稿:  可
記事編集: 不可
記事削除: 不可
ファイル添付: 不可

検索:
ページ移動:  
Powered by MozillaZine.jp® Forum Software © phpBB Group , Almsamim WYSIWYG
Japanese translation principally by ocean