― MozillaZine.jp フォーラムは Mozilla 製品に関する情報交換の場です ―



All times are UTC + 9 hours

新しいトピックを投稿する トピックへ返信する  [ 2 件の記事 ] 
作成者 メッセージ
投稿記事Posted: 2008年11月30日(日) 14:46 
件名の通りにfennecのWM6対応ビルドについて質問です。

公式のBuild情報に即して、fennecをVisualStudio 2008 Proにてビルドしています。
現在は、コンパイル自体は完了しており、fennec.exeが作成されている状況です。

しかし、デバッグの為にfennecを起動しようとするとデバイス上にて"Couldn't load XPCOM"と表示され起動できません。xulrunner.exeは一応起動し、終了します。しかし、xulrunner-sub.exeは同様のエラーのために起動できません。

デバッガで追うと、
Error loading xul.dll: The parameter is incorrect.
Error loading xpcom.dll: The parameter is incorrect.
と言われています。WM6の制限のため、DLLをfennec.exeと同ディレクトリ内に保持しているにも関わらず上記エラーの為に起動も出来ません。
xulrunner.exeでは同条件ながらもxul.dllとxpcom.dllはロード出来ています。

解決方法をご存知の方がいらっしゃいましたら、ご教示をよろしくお願いいたします。


通報する
ページトップ
  
引用付きで返信する  
投稿記事Posted: 2008年12月03日(水) 23:36 
読み込みが出来るようになったので、経過を報告します。

以前から指摘されている LoadLibraryExW の flag の問題でした。
LOAD_WITH_ALTERED_SEARCH_PATH の flag はWMではサポートされていないと言う事は以前から指摘されていましたが、サポートされていない為に無視をしているのかと思っていましたが、エラーとなりDLLがロードされないと言う事態になっていました。

DLLのロード周りに関しては色々と厄介なようで、 LOAD_WITH_ALTERED_SEARCH_PATH を外すと、fennec.exeと同じディレクトリにdllが無くてはいけない、dllが移動しているので、dllから読み込んだりするファイル群も相対的に同じ位置に無くてはいけないと言う事になっています。

XPCOM周りでエラーが出てfennecのアプリ画面までは辿りつけていませんが、何とかfennecのデバッグとして意味のあるエラーを吐く所までは到達しました。


通報する
ページトップ
  
引用付きで返信する  
期間内表示:  ソート  
新しいトピックを投稿する トピックへ返信する  [ 2 件の記事 ] 

All times are UTC + 9 hours


オンラインデータ

このフォーラムを閲覧中のユーザー: なし & ゲスト[0人]


トピック投稿:  可
返信投稿:  可
記事編集: 不可
記事削除: 不可
ファイル添付: 不可

検索:
ページ移動:  
Powered by MozillaZine.jp® Forum Software © phpBB Group , Almsamim WYSIWYG
Japanese translation principally by ocean