― MozillaZine.jp フォーラムは Mozilla 製品に関する情報交換の場です ―



All times are UTC + 9 hours

返信する
ユーザー名:
件名:
オプション:
BBCode: ON
[img]: ON
[flash]: OFF
[url]: ON
スマイリー: ON
BBCode を無効にする
スマイリーを無効にする
URL を自動的にパースしない
ユーザエージェントを表示する
認証コード
KCaptcha by Nikita_Sp
   

トピックのレビュー - 「メッセージを検索」が正しい結果を返してくれない
作成者 メッセージ
  記事の件名:  Re: 「メッセージを検索」が正しい結果を返してくれない  引用付きで返信する
ありがとうございます。

DTIのメールサービスを利用していますが、サーバー上に存在していることは確認済みです。

いずれにせよ、私だけがこのような状態になるのは、私の使い方がおかしいからでしょう。
確かに、複数のPCやスマホでDTIにアクセスしていますし・・・・。

ちなみに、「同期とディスク領域」の設定で「このコンピューターのこのアカウントのすべてのフォルダーを保存する」にチェックを入れていたので、

このチェックを外して、global-messages-db.sqlite を再作成して、「サーバー上のメッセージを検索」にチェックを入れたところ、正しく検索でき
るようになりました。(少し時間は掛かりますが)
投稿記事 Posted: 2019年6月15日(土) 21:58
  記事の件名:  Re: 「メッセージを検索」が正しい結果を返してくれない  引用付きで返信する
ataguchi さんが書きました:
PS:「サーバー上のメッセージを検索」は、IMAP利用時は、指定してはいけないんでしょうか。そんなことはないですよね。

「サーバー上のメッセージを検索」はIMAPのためのオプションでPOPにはありません。
IMAPアカウントでの話というのも初耳ですし、どちらのメールサービスをご利用かは知りませんが、IMAPサーバーが対応して無い(そんなバカな…)か、なんらかの不調ということかと。
そもそも検索で見つからないメールは本当にIMAPサーバー上に存在していますか?
投稿記事 Posted: 2019年6月15日(土) 21:24
  記事の件名:  Re: 「メッセージを検索」が正しい結果を返してくれない  引用付きで返信する
早々のアドバイス、ありがとうございます。

「フォルダーの修復」を実施しただけでは状況は変わりませんでしたが、検索で「サーバー上のメッセージを検索」のチェックを外したら、正しい検索結果が返ってくるようになりました。

ありがとうございました。


PS:「サーバー上のメッセージを検索」は、IMAP利用時は、指定してはいけないんでしょうか。そんなことはないですよね。
投稿記事 Posted: 2019年6月15日(土) 10:15
  記事の件名:  Re: 「メッセージを検索」が正しい結果を返してくれない  引用付きで返信する
Peter さんが書きました:
「メッセージを検索」で特定のフォルダを指定して「本文」検索をすると、本来であれば何らか検索結果を返すはずが、「見つかりませんでした」となってしまいます。

フォルダーペイン(Thunderbird左側の画面)にてそのフォルダーを選択、右クリックからプロパティを開き、一般情報>「フォルダーを修復」を実行してみるとどうでしょうか。

Peter さんが書きました:
念のため、global-messages-db.sqlite は一度削除して、再作成してみたのですが、変化はありませんでした。

Thunderbird でメールを検索する機能は下記があります。

  • このメッセージ内を検索(ページ内検索): Ctrl + F
  • メッセージを検索(検索ダイアログ): Ctrl + Shift + F
  • グローバル検索(ツールバーにある検索欄): Ctrl + K
  • このフォルダーのメッセージを絞り込む(クイックフィルターバー): Ctrl + Shift + K
 
global-messages-db.sqlite というファイルは「グローバル検索」の場合に使われるものであり、「メッセージを検索」では関係ありません。
投稿記事 Posted: 2019年6月15日(土) 00:35
  記事の件名:  「メッセージを検索」が正しい結果を返してくれない  引用付きで返信する
いつからかはわからない(恐らく1か月以内?)のですが、「メッセージを検索」が正しい結果を返してくれなくなりました。

「メッセージを検索」で特定のフォルダを指定して「本文」検索をすると、本来であれば何らか検索結果を返すはずが、「見つかりませんでした」となってしまいます。

アカウント全体で同様の検索をしても、一部については正しく結果を返してくれますが、一部は検索から漏れてしまいます。


私の環境は、以下のとおりです。
バージョン:60.7.1
OS:Windows10 (1903)


念のため、global-messages-db.sqlite は一度削除して、再作成してみたのですが、変化はありませんでした。

何かご存じの方、アドバイスをお願いします。
投稿記事 Posted: 2019年6月14日(金) 15:58

All times are UTC + 9 hours


ページ移動:  
Powered by MozillaZine.jp® Forum Software © phpBB Group , Almsamim WYSIWYG
Japanese translation principally by ocean