― MozillaZine.jp フォーラムは Mozilla 製品に関する情報交換の場です ―



All times are UTC + 9 hours

新しいトピックを投稿する トピックへ返信する  [ 3 件の記事 ] 
作成者 メッセージ
投稿記事Posted: 2019年12月11日(水) 19:36 
オフライン

登録日時: 2017年4月14日(金) 18:19
記事: 259
Mozilla removes site specific user-agent override option from Firefox 71 | gHacks Tech News
(Firefox 71 から、サイト固有のユーザーエージェントオーバーライドオプションが削除されています)
https://www.ghacks.net/2019/12/11/mozil ... irefox-71/
by Ashwin on December 11, 2019

その要旨(意訳)
Firefox 71 release(安定)版からは、「about:config」ページが新しいインターフェースに変更されました。
とりわけ、重要な変更点は「about:config から、サイト固有のユーザーエージェントオーバーライドオプションが削除された」ことです。
そのため、UserAgent 文字列を使用して、サイト固有のオーバーライドを設定することができなくなりました。
グローバルオーバーライド(ユーザーエージェント:Firefox)が強制されるので、一部の Web サイトの(Twitter、YouTube は、旧式のデザインを使用しているので)レンダリングが奇妙になる場合があります。
「Firefox」では表示できない Skype Web(Chrome か、Edge のユーザーエージェントが必要)、インターネットバンキング Web サイトなどは「サイトが指定するユーザーエージェントが必要」になります。

Firefox を使用する場合での「回避策」は、下記の 2つに限られますが、手間や安全性の観点で「② アドオン利用が最良」です。
① 非延長法:
新しいタブを開いて、about:config を入力し、表示される検索ボックスに次のテキストを貼り付けます。
general.useragent.override
新しい設定がタブに表示され、[文字列] オプションを選択して、右側のプラスボタンをクリックします。
② アドオンでの対処法:
User-Agent Switcher and Manager
https://addons.mozilla.org/ja/firefox/a ... -switcher/
などのアドオンを使用し、(ホワイトリストモードに)各サイトのユーザーエージェントを手動で設定することです。
Chameleon もお勧めです(日本語で利用できます):ユーザーエージェントのプリセットリストから選択できます。
https://addons.mozilla.org/ja/firefox/a ... eleon-ext/

注意点:
Firefox 以外のユーザーエージェントを使用した状態のままでは、「AMO(addons.mozilla.org)から、拡張機能をダウンロードすること」ができなくなります。
---------------------------------

因みに「Chameleon」を使用し、
プリセットリストから「Mozilla/5.0 (Macintosh; Intel Mac OS X 10_12_6) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/11.1.1 Safari/605.1.15」を選択して、投稿してみました。

_________________
Mozilla/5.0 (Macintosh; Intel Mac OS X 10_12_6) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/11.1.1 Safari/605.1.15


通報する
ページトップ
 プロフィール  
引用付きで返信する  
投稿記事Posted: 2019年12月12日(木) 07:12 
オフライン

登録日時: 2017年4月14日(金) 18:19
記事: 259
「Web ブラウザ用の最新のユーザーエージェント」の最新リスト:

What are the latest user agents for popular web browsers? | WhatIsMyBrowser.com
(一般的な Web ブラウザーの最新のユーザーエージェントは?)
https://www.whatismybrowser.com/guides/ ... ser-agent/
以下、要旨(意訳)
一般的なすべての Web ブラウザーの最新のユーザーエージェントの常に最新のリストを作成しました。
これらのユーザーエージェントは、常に各ブラウザーの現在のユーザーエージェントを表示します。
それは、素晴らしい Browser Versions API によって強化されています 。
ご自身のシステムで必要なものである場合は、チェックしてください。

最新のChromeユーザーエージェント
最新のFirefoxユーザーエージェント
最新のSafariユーザーエージェント
最新のInternet Explorerユーザーエージェント
最新のEdgeユーザーエージェント
最新のOperaユーザーエージェント
最新のVivaldiユーザーエージェント
最新のYandex Browserユーザーエージェント

ブラウザーの最新のユーザーエージェントを知る必要があるのはなぜですか?
ほとんどの「通常の」ユーザーは、
この種のことを知る必要はありません。 せいぜい Cookie を有効にしているかどうかに興味がある程度でしょう。
ただし、
一部の Web サイトは「使用を許可する Web ブラウザーについて非常に厳密」です。
一部の Web サイトでは、ブラウザーが Web サイトを正常に表示できる場合でも、アクセスを許可しません。 それはかなり非友好的な行動です! 最近まで、Netflix は Linux オペレーティングシステムを実行しているユーザーが Netflix にアクセスすることを許可しませんでした。 有料の顧客であっても。

したがって、
これらの種類のブロックを回避するための 1つの一般的なトリックは、Web ブラウザーのユーザーエージェントを変更することです。
そのため、Web サイトの使用を「許可」されている別のブラウザを使用しているように偽装します。
これを行うには、偽装したいブラウザの最新のユーザーエージェントが何であるかを知る必要があります。

ユーザーエージェントを要求する、もう 1つの理由は、
サーバーログをチェックして、最新バージョンの Web ブラウザーでサイトにアクセスしたユーザーの数を確認したいシステム管理者の都合もあるようです。

どちらにしても、
ブラウザごとに最新のユーザーエージェントが何であるかを知る必要があります。

API 経由で Web ブラウザのバージョン番号が必要ですか?
ブラウザバージョンAPI は、必要なものだけを提供します! これは強力な API の一部であり、利用可能な最高のユーザーエージェントパーサーにもアクセスできます。 API を介してアクセスされるため、システムを構築したソフトウェア言語に関係なく、現在のシステムで使用できます。 また、ソフトウェアライブラリの更新について心配する必要もありません。 常に最新です!

_________________
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:68.0) Gecko/20100101 Firefox/68.0


通報する
ページトップ
 プロフィール  
引用付きで返信する  
投稿記事Posted: 2019年12月12日(木) 10:10 
オフライン

登録日時: 2017年4月14日(金) 18:19
記事: 259
Firefox 71 から、
サイト固有のユーザーエージェントオーバーライドオプションが削除された理由について
Bug 1513574 | Remove UserAgentOverrides.jsm
https://bugzilla.mozilla.org/show_bug.cgi?id=1513574
Opened Last year
Closed 3 months ago
に、
詳述されていました。
下記に、その要旨(意訳)
UserAgent Overrides は、パフォーマンスと正確さの理由から、C++サービスとして書き換える必要があります。
ですから、UserAgentOverrides.jsm はもう必要ありません。
nsIDocshell.customUserAgent を使用して修正できます。つまり、UserAgentOverrides.jsm と UserAgentUpdates.jsm の必要性はほとんどなくなりました。
また、nsILoadGroup および nsIRequestContext に接続された UA キャッシュと「http-on-useragent-request」オブザーバー通知を削除します。
ユーザーエージェントをオーバーライドする必要がある場合は、「http-on-modify-request」も同様に使用できます(ただし、パフォーマンス上の理由からほとんど使用しないでください)。より良い方法は、nsIDocShell.customUserAgent を使用することです。
はるかに信頼性の高い方法でユーザー名を変更できる多くの Web拡張機能(アドオン)があります。
AMO(addons.mozilla.org)から、好きなものを選んでください。

ドメイン固有の部分が削除された特別な理由はありましたか?確実に機能し、拡張機能をインストールするよりもはるかにエレガントでした。

はい。このコードは非常に非効率的で、すべてのロードで実行され、サイト固有の UA 設定が存在するかどうかを暴露しました。
さらに、UA の変更はサブリソースのロードではなく、トップレベルのロードでのみ発生するという古いバグがありました。
とにかく、悪く、非効率的で、バグが多かった。
ユーザーがこの変更を(拡張機能:アドオンを介して)実行し、Mozilla が UA の介入を実行する(アドオンを介して)より良い方法があります。
about:config prefs によって制御されるものは、遅かれ早かれ壊れます。テストできる構成は少数であり、以前と同様に、UserAgent を変更する方法が複数あるということは、すべての構成が十分にテストされていないことを意味します。そして、これを行うコードを維持する技術的な負担は(「バグがない」と仮定しても)価値がありません。
あなた方が望む「設定を追加する手法が便利だった」に同意しますが、
拡張機能(アドオン)はそれと同等のことを簡単に行うことができ、十分にテストされています。

_________________
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:68.0) Gecko/20100101 Firefox/68.0


通報する
ページトップ
 プロフィール  
引用付きで返信する  
期間内表示:  ソート  
新しいトピックを投稿する トピックへ返信する  [ 3 件の記事 ] 

All times are UTC + 9 hours


オンラインデータ

このフォーラムを閲覧中のユーザー: Google [Bot], MSN [Bot] & ゲスト[6人]


トピック投稿:  可
返信投稿:  可
記事編集: 不可
記事削除: 不可
ファイル添付: 不可

検索:
ページ移動:  
Powered by MozillaZine.jp® Forum Software © phpBB Group , Almsamim WYSIWYG
Japanese translation principally by ocean