― MozillaZine.jp フォーラムは Mozilla 製品に関する情報交換の場です ―



All times are UTC + 9 hours

新しいトピックを投稿する トピックへ返信する  [ 11 件の記事 ] 
作成者 メッセージ
投稿記事Posted: 2012年1月31日(火) 08:45 
会社のメーラーとしてThunderbird8を使用しています。

先日、メールサーバがSSL対応となったので、設定を変更した所
メール送信画面のプログレスバーが99%で固まるようになりました。
(いつまで経っても100%にならずバーが消えない状態です)

SMTPサーバやポート等の設定が間違っていないか確認した所、
とくに問題ないようでした。

原因がわからず、バージョンを3.1にし、同じように送信したら
プログレスバーが100%となり、正常に送信できました。

現在バージョンが9まで出ていますが、9でも送信ができないことを確認しました。
どなたか原因を教えてもらえないでしょうか。


通報する
ページトップ
  
引用付きで返信する  
投稿記事Posted: 2012年1月31日(火) 09:41 
オフライン

登録日時: 2006年9月05日(火) 18:47
記事: 4210
 
*質問・投稿する前に フォーラムの利用について を読んでその内容を理解した上で
 それに沿って投稿しましょう。
*ご自分の利用環境として OS の種類、Thunderbird の正確なバージョンぐらいは書
 き添えましょう。
*質問した後やアドバイスをもらった後には結果や経緯を必ず書くようにしましょう。

 
 
一般的な送信トラブルの対処確認は以下です。
今一度、落ち着いて確認してみてください。

メッセージが送信できない | トラブルシューティング | Thunderbird ヘルプ
メールの送受信ができない | Thunderbird サポート


manabu さんが書きました:
SMTPサーバやポート等の設定が間違っていないか確認した所、
とくに問題ないようでした。

念のため、その送信サーバ(SMTP)のユーザ ID、パスワード以外の推奨設定内容を提示
してください。
そして Thunderbird のアカウント設定でどのように設定しているのかも併せて提示して
ください。


【補足】
企業内のシステムのサーバ環境がどうなっているのか不明ですが、プロキシなどの接続条
件も併せて確認してみてください。
また SSL の場合、希にサーバ側の証明書で問題が起きることがあります。
それらも確認しておきましょう。
 


通報する
ページトップ
 プロフィール  
引用付きで返信する  
投稿記事Posted: 2012年1月31日(火) 11:51 
kiki様、ご返信ありがとうございます。
わかる範囲で情報を記入致しました。

kiki さんが書きました:
*質問・投稿する前に フォーラムの利用について を読んでその内容を理解した上でそれに沿って投稿しましょう。


大変失礼いたしました。
PCの環境を書いていませんでした。

OS:Windows XP Pro SP3
Thunderbird Ver:3.1.17
  (※Ver 8や9でうまく送信できないので、Ver 3.1.17を使用しています。)
  (※Ver 3.1系であれば正常に動作するため今はこれを使用しています。)

です。

kiki さんが書きました:
念のため、その送信サーバ(SMTP)のユーザ ID、パスワード以外の推奨設定内容を提示してください。


承知いたしました。
メールサーバ(アルファメールプラチナ)を使用し、「SMTP over SSL」「POP over SSL」により
送受信経路を暗号化しております。
推奨設定内容は(SMTPのみの提示です)
◎「SMTP over SSL」を利用する場合
  「このサーバーはセキュリティで保護された接続(SSL)が必要」にチェックボックス
 「送信メール(SMTP)ポート」 "465" を入力

*設定の内容はOutlookExpressですが、同様のことをThunderbirdに設定しているつもりです。

Thunderbirdアカウント設定内容
・送信(SMTP)サーバの設定項目
 サーバー名:smtp.alpha-plt.jp
 ポート番号:465 (規定値:465)
 接続の保護:SSL/TLS
 認証方式:暗号化されたパスワード認証
 ユーザ名:*****%*****.co.jp

kiki様が知りたい情報とは的外れになっている可能性があると思います。
大変お手数をおかけいたしますが、その際はよろしくお願いいたします。


通報する
ページトップ
  
引用付きで返信する  
投稿記事Posted: 2012年1月31日(火) 13:34 
オフライン

登録日時: 2006年9月05日(火) 18:47
記事: 4210
 
「認証方式:暗号化されたパスワード認証」を下記のように「通常のパスワード認証」に
変えたらどうなりますか。

  
 

上記でも改善されない場合は、一旦その送信サーバ設定を削除後に Thunderbird を再起動
させて、再度新規に送信サーバ設定を作成してみてください。
 #該当のアカウント設定の [送信(SMTP)サーバ:] の指定を忘れずに。
 
 
【余談】
Thunderbird の異なるバージョンで、同じプロファイルを使い回すのは避けた方が無難です。
できればプロファイルも別途作成して、使い分けた方がいいでしょう。
 


通報する
ページトップ
 プロフィール  
引用付きで返信する  
投稿記事Posted: 2012年2月08日(水) 12:50 
こんにちは。しばらく日が空いてしまってすいません。

Thunderbird10がリリースされたので、そちらに変えてみましたが
変化ありませんでした。
また、Thunderbird3.1.18もリリースされましたが、やはり3.1系でやれば
正常にメールの送信が完了することを確認しました。

引用:
「認証方式:暗号化されたパスワード認証」を下記のように「通常のパスワード認証」に
変えたらどうなりますか。


「通常のパスワード認証」に変えてみましたが、やはりダメでした。。
kiki様が仰っているとおりプロファイルを複数作ってみましたが、そちらもうまくいきませんでした。


いろいろなパターンをやってみて、1つわかったことですが
添付ファイルをつけて送信すると、送信時のプログレスバーが99%で固まることが多い
ということがわかりました。 
添付ファイルなしでは正常に送信できました。
(表現的には難しいのですが「必ず起こる」わけではないようです。)


通報する
ページトップ
  
引用付きで返信する  
投稿記事Posted: 2012年2月08日(水) 14:18 
オフライン

登録日時: 2006年9月05日(火) 18:47
記事: 4210
 
添付ファイル付きのメッセージが送信できないのですね。

Thunderbird 側のバグの可能性も考えられますが、ルータまわりの仕様かも知れませんので以下を
試して改善されるか確認してみてください。

1.Thunderbird の ツール メニューをクリックし、オプション を選択します。
2.[詳細] > [一般] > [高度な設定] > [設定エディタ] をクリックして about:config ウィンドウ
  を開きます。
3.フィルタ 欄に network.tcp.sendbuffer と入力して、"値" の列をクリックします。
  デフォルトは [131072] です。
  これを [65536] > [32768] > [16384] に順次変更して、その都度添付ファイル付きのメッセ
  ージ送信をおこなってみてください。

   #いろいろな形式およびサイズの添付ファイルでテストしてください。
   #数値の変更後は必ず Thunderbird を再起動してください。
 
[参照]
[解決済み] 添付ファイルを送信するとタイムアウトになって送信できません
 


通報する
ページトップ
 プロフィール  
引用付きで返信する  
投稿記事Posted: 2012年2月09日(木) 10:08 
私の所でも良く似た現象が発生しています。
同じく大塚商会にメールサービスをアウトソースしています。
アルファメールプレミアの契約になります。
(プラチナとプレミアは少し違うかもしれません)

Thunderbirdのバージョン5.0以上(現在10.0)で、
メール送信時にタイムアウトになる現象が発生。

現象
 ・送信自身は成功している。
 ・送信が正常に完了する時もある、添付ファイルがあると高確率で発生。
 ・他のメールソフト(OutlookExpress等)やver.3では発生していない。

大塚商会に問い合わせてみると
 ・通信経路の暗号化
 ・添付ファイルの使用
 これらの場合に現象が発生すると言う事は確認しているがThunderbirdはサポート外で
 ソフト側のバグだと説明していました。
 確かにver.3では問題無かったので何らかの実装の変更が影響していると思われます。
 過去ログによると暗号化せず Submissionでないポート25番のSMTPだと問題無い様です。

 ちなみにThunderbirdの通信ログを見てみると、"entering state: 8、Send: . "
 以降がタイムアウト時には出来ていない様です。
 Thunderbird側の問題なのかサーバ側かどちらかでしょう。

コード:
~省略~
SMTP entering state: 0
SMTP Response: 250 Recipient <aaaaa@bbbbb.co.jp> Ok
SMTP entering state: 6
SMTP Send: DATA

SMTP entering state: 0
SMTP Response: 354 Ok Send data ending with <CRLF>.<CRLF>
SMTP entering state: 7
SMTP entering state: 8
SMTP Send: .
※タイムアウト時は、ここ以降が記録されていません。

SMTP entering state: 0
SMTP Response: 250 Message received: xxxxxxxx@[111.222.333.444]
SMTP entering state: 9
SMTP Send: QUIT

SMTP entering state: 0
SMTP entering state: 0
SMTP Response: 221 xxxxxxxx.alpha-prm.jp ESMTP server closing connection
SMTP entering state: 10
SMTP entering state: 12


PC環境
   OS: Windows XP Professional SP3
  MUA: Thunderbird ver.10.0

 アカウント設定-送信(SMTP)サーバの内容
 サーバー名:smtp.alpha-prm.jp
   ポート:465
  認証方式:任意の安全な方式 (非推奨)
       (通常のパスワード認証)
 接続の保護:SSL/TLS
 ※アカウント設定はver3の時から使い続けていたので
  認証方式が通常とは違う様です。
  別PCに新規インストールしても同じでした、その時の
  認証方式は通常のパスワード認証です。

参考:送信できているのに「タイムアウト」
http://forums.mozillazine.jp/viewtopic.php?p=42278


通報する
ページトップ
  
引用付きで返信する  
投稿記事Posted: 2012年2月13日(月) 17:35 
また、少し日が空いてしまいました。すいません。

Thunderbirdを最新の10にアップデートした状態で、
「network.tcp.sendbuffer」を131072から16384に数字を下げるとうまく送れるように
なりました。

今の所それによる不具合はありませんです!

kiki様、ありがとうございました!


通報する
ページトップ
  
引用付きで返信する  
投稿記事Posted: 2012年2月17日(金) 09:28 
お世話になります。

「network.tcp.sendbuffer」を16384でしばらくうまく行っていたのですが
今朝再び添付ありメール送信時にタイムアウトになりました。。

これを 8192 → 4096 → と値を小さくしていけば
成功率が高くなるのでしょうか・・・?


通報する
ページトップ
  
引用付きで返信する  
投稿記事Posted: 2012年2月17日(金) 12:35 
横から失礼します。

manabu さんが書きました:
「network.tcp.sendbuffer」を16384でしばらくうまく行っていたのですが
今朝再び添付ありメール送信時にタイムアウトになりました。。

これを 8192 → 4096 → と値を小さくしていけば
成功率が高くなるのでしょうか・・・?

この値は、ご利用のネットワーク環境との組み合わせに依るはずですから、第三者には最適値はわからないと思います。
(一般に、Mozilla 製品が想定しているネットワーク条件はけっこう高めで、そのような条件に合う初期値でネットワークまわりの設定が施されていることが多いと思います。)

manabu さんが書きました:
また、Thunderbird3.1.18もリリースされましたが、やはり3.1系でやれば
正常にメールの送信が完了することを確認しました。

ということであれば、Thunderbird 10.0 系のネットワークまわりの諸設定の初期値を、3.1 系のそれに合わせてみると改善が望めるかもしれません。
ただ、法人内利用のようですし、ご利用環境の諸条件を詳細には把握できない第三者では、どこをどうしろとはいえません。
ご自身で試していただくことになろうかと思います。

(参考 - ネットワークまわりの初期値で 10.0 と 3.1 に顕著な違いがあるもの)
Thunderbird _______________ 10.0 ________ 3.1
network.buffer.cache.size_____ 32768 _______ 4096
network.http.max-connections__ 256 _________ 30

※この値が問題だといっているわけではありません。大きな差があるものの一例を抜き出しただけです。
※network.tcp.sendbuffer の初期値はどちらも 131072 ですが、この値はネットワーク環境によっては問題が起こるケースがあるようです。
※タイムアウトについては、mailnews.tcptimeout の値(初期値 100 <秒>)を少し上げてみると、エラーの出現を多少は緩和できるかもしれません。ただし、上げすぎないでください。

とりあえず以上です。的外れだったらすみません。


通報する
ページトップ
  
引用付きで返信する  
投稿記事Posted: 2012年2月25日(土) 11:26 
またしばらく日が空いてしまいました。すいません。

偶然的通行人様が仰ってる通り
network.http.max-connections
network.buffer.cache.size
を変更してみましたが、状況は変わらずでした。

タイムアウトになりますがメールは送れているみたいです。
しかし本当に送れているか心配になってきます。


通報する
ページトップ
  
引用付きで返信する  
期間内表示:  ソート  
新しいトピックを投稿する トピックへ返信する  [ 11 件の記事 ] 

All times are UTC + 9 hours


オンラインデータ

このフォーラムを閲覧中のユーザー: なし & ゲスト[14人]


トピック投稿:  可
返信投稿:  可
記事編集: 不可
記事削除: 不可
ファイル添付: 不可

検索:
ページ移動:  
Powered by MozillaZine.jp® Forum Software © phpBB Group , Almsamim WYSIWYG
Japanese translation principally by ocean