― MozillaZine.jp フォーラムは Mozilla 製品に関する情報交換の場です ―



All times are UTC + 9 hours

新しいトピックを投稿する トピックへ返信する  [ 14 件の記事 ] 
作成者 メッセージ
投稿記事Posted: 2009年7月26日(日) 08:52 
地図サイトのいつもNAVIを見ようとすると「Firefox 3.5のブラウザのユーザーエージェントを変更すれば、スクロール地図が利用できる」と解説され、アドオン「User Agent Switcher」の導入をすすめています。
最初は、サイトの問題かと思いましたが、ページの最後に「Firefox3.5が正規に対応するまで」と但し書きがありますが、Firefox3.5側の問題とはなんでしょうか?


Mozilla/5.0 (Windows; U; Windows NT 5.1; ja; rv:1.9.1.1) Gecko/20090715 Firefox/3.5.1 (.NET CLR 3.5.30729)


通報する
ページトップ
  
引用付きで返信する  
投稿記事Posted: 2009年7月26日(日) 08:58 
> 「Firefox 3.5のブラウザのユーザーエージェントを変更すれば、スクロール地図が利用できる」と解説され

どこに書かれていますか?


通報する
ページトップ
  
引用付きで返信する  
投稿記事Posted: 2009年7月26日(日) 09:07 
↓こちらです。
http://www.its-mo.com/stc/help/ff35-con ... action=all


通報する
ページトップ
  
引用付きで返信する  
投稿記事Posted: 2009年7月26日(日) 09:43 
この手の地図はJava Scriptを使ったものだと思います。
UA変更で解決するので、Firefoxの問題ではなく、サイト側の問題だと思います。

「Firefox3.5 正規に対応するまで」
ではなく、
「Firefox3.5 正規に対応するまで」
というほうが、正確かと思います。


通報する
ページトップ
  
引用付きで返信する  
投稿記事Posted: 2009年7月27日(月) 19:17 
オフライン
Moderator

登録日時: 2006年11月22日(水) 11:54
記事: 608
お住まい: 琵琶湖・淀川流域
以下の内容を問い合わせ用フォームから送信して問い合わせしてみましたところ、回答がありました。
ぼてじゃこ さんが書きました:
貴サイトには以下の様な説明がありますが、ユーザエージェントでUAを偽装すれば利用可能であるということは、
Firefox がスクロール地図の機能に対応していないのではなく、
スクロール地図が UA による判定で Firefox を排除しているに過ぎないのではありませんか。

Firefox3.5でスクロール地図をご利用になるには さんが書きました:
Firefox 3.5は現在スクロール地図に対応しておりません。ご不便をお掛けして誠に申し訳ございません。
解決策としてFirefox 3.5のブラウザのユーザーエージェントを変更すれば、スクロール地図がご利用いただけます。


回答の内容は以下の通り(社交辞令部分は割愛してあります)
「いつも NAVI 」回答メール さんが書きました:
誠に恐れ入りますが、現在のところスクロール地図はFirefox3.5では
正常に表示することが出来ないため、クリック地図が表示されます。

なお、スクロール地図について、Firefox3.5でも表示できるよう
出来るだけ早く対応をさせる予定ではおりますが、対応完了までに時間
がかかってしまう場合もございますこと、あらかじめご了承の程
お願いいたします。

ご不便をおかけいたしまして大変恐縮ですが、ユーザーエージェントを
変更いただくか、他のブラウザにてお試しいただけますと幸いです。


やはり、サービスの機能が Firefox3.5 には対応できていないに過ぎません。


通報する
ページトップ
 プロフィール  
引用付きで返信する  
投稿記事Posted: 2009年7月27日(月) 20:57 
オフライン
Administrator

登録日時: 2005年6月23日(木) 23:29
記事: 2452
お住まい: 東京
ぼてじゃこ さんが書きました:
「いつも NAVI 」回答メール さんが書きました:
誠に恐れ入りますが、現在のところスクロール地図はFirefox3.5では
正常に表示することが出来ないため、クリック地図が表示されます。

なお、スクロール地図について、Firefox3.5でも表示できるよう
出来るだけ早く対応をさせる予定ではおりますが、対応完了までに時間
がかかってしまう場合もございますこと、あらかじめご了承の程
お願いいたします。

ご不便をおかけいたしまして大変恐縮ですが、ユーザーエージェントを
変更いただくか、他のブラウザにてお試しいただけますと幸いです。


やはり、サービスの機能が Firefox3.5 には対応できていないに過ぎません。

かなりアホな応対ですねぇ。
「ユーザーエージェントを変更」で問題ないのであればサーバ側でのブラウザの判定ロジックを修正すればいい話であり、完全にあちらの怠慢です。
UA の "Firefox/x.x.x.x" の数字の部分見てるんだと思いますが、数文字書き換えれば済むでしょうに。

_________________
[Desktop] Windows 7 Professional SP 1 (64bit) / Intel Core i7-2600 / AMD Radeon HD 7870 / 16 GB Memory
[Laptop] Windows 7 Professional SP 1 (64bit) / Intel Core i5-520M vPro / Intel HD Graphics / 8 GB Memory
常用環境: Firefox Beta (Win64 x86-64), Thunderbird Beta + Lightning Beta (Win32)
テスト環境: Firefox ESR, Firefox Release, Firefox Developer Edition, Firefox Nightly (Win64 x86-64)

Cai/1.0 (Homo sapiens; N; Homo sapiens chemist; male; rv:0.0.3.5+)
-- いつまでたっても nightly


通報する
ページトップ
 プロフィール  
引用付きで返信する  
投稿記事Posted: 2009年7月28日(火) 07:02 
オフライン
Moderator

登録日時: 2006年11月22日(水) 11:54
記事: 608
お住まい: 琵琶湖・淀川流域
Cai さんが書きました:
かなりアホな応対ですねぇ。
「ユーザーエージェントを変更」で問題ないのであればサーバ側でのブラウザの判定ロジックを修正すればいい話であり、完全にあちらの怠慢です。
UA の "Firefox/x.x.x.x" の数字の部分見てるんだと思いますが、数文字書き換えれば済むでしょうに。


「まぁ、ユーザエージェントで切り替えろって言うんだから切り替えてやるよ」と早速、試してみました。
ついでに推奨環境( IE6、Firefox 2 )以外のブラウザもいれてある奴、全部を試して見ました。

で、結果発表・・・
IE8 ( 「いつもNAVIの推奨環境」では正常に動作しない筈だが ) : 問題なく動作
Google Chrome Dev. 3.0.195.1 ( 推奨環境では触れられもしていないが ) : 問題なく動作
素のままの Firefox 3.5.1 : UserAgentSwitcher のインストールを呼びかけるページに転送
仰せのとおりに切り替えた Firefox 3.5.1 : 今度は「 Flash Player を最新版にせい」と云う。地名・住所をキーワードにした検索では動作しました
駄目元で素のままの Minefield 3.6a1pre. : Firefox 3.5.1 と同じ扱われ方です
ちなみに Firefox3.5.1 も Minefield も Firefox2.0 と偽装しました。
ちなみに Nifty 地図での javascript も通しておく必要があるようです。

Firefox 3.5x や Minefield でも UA の偽装だけでほぼ問題なく動作するところを見ると
ver. 3.5以降の Firefox に問題があるのではなく、サービス側の対応が進んでいないだけのようです。
( 多分 Nifty 地図の方でも javascript を通しておかないと駄目なところを見ると技術面は Nifty 任せなのかも)
結局、このサービスは「 Firefox はなるだけ排除」と云う方針のようです。
しかし、正常に動作しない筈の IE8 や、Google Chrome のしかも dev. channel 版では動作したりと云う事から、
告知面や運用面は随分とルーズなのか恣意的なのか、結果としてユーザを馬鹿にしている事は確かです。


通報する
ページトップ
 プロフィール  
引用付きで返信する  
投稿記事Posted: 2009年7月28日(火) 09:13 
オフライン
Moderator

登録日時: 2007年7月25日(水) 09:52
記事: 415
お住まい: 東京都下
#「Web標準」フォーラムのほうが適切とのご指摘がありましたので移動させていただきました。
 2009/07/28 (Tue) by Moderator Sakiba


ところで横からすみません。

例えば UA の偽装(あえてこの言葉を使います)で対応したとした場合、他のきちんと UA 判断
しているサイトで問題が発生する可能性というのは無いのでしょうか? また、現状は問題なくても
将来的に問題が起きる可能性もありますよね?

一般的なユーザーの場合、一旦 UA を偽装設定してしまうと、その後そのサイトが対応したと
しても、UA を元に戻す事を意識している人というのは少ないような気もします。Firefox の
バージョンアップを行えば、自動的に更新されるのかもしれませんが。(でも、その都度また
そのサイトで UA 偽装を指示されるのでしょうか? :lol:

そういった点からその「いつもNAVI」側の対応は無責任なのではないかと感じてしまいます。


通報する
ページトップ
 プロフィール  
引用付きで返信する  
投稿記事Posted: 2009年7月28日(火) 10:05 
オフライン

登録日時: 2005年12月19日(月) 23:05
記事: 88
Sakiba さんが書きました:
例えば UA の偽装(あえてこの言葉を使います)で対応したとした場合、他のきちんと UA 判断
しているサイトで問題が発生する可能性というのは無いのでしょうか? また、現状は問題なくても
将来的に問題が起きる可能性もありますよね?

すぐに思いつく問題として、Firefox3.5.1でUAをFirefox3.0.9だと設定した場合、Firefox3.5以降に追加された何らかの機能を利用したページが利用できなくなります。
具体例を挙げると、確かCSSのプロパティが追加されていた気がします。

同じくFirefox3.5.1でUAをIE7だとした場合、本当のIE7では動く機能が動かないなんてこともありそうです。

Sakiba さんが書きました:
一般的なユーザーの場合、一旦 UA を偽装設定してしまうと、その後そのサイトが対応したと
しても、UA を元に戻す事を意識している人というのは少ないような気もします。Firefox の
バージョンアップを行えば、自動的に更新されるのかもしれませんが。(でも、その都度また
そのサイトで UA 偽装を指示されるのでしょうか? :lol: )

そういった点からその「いつもNAVI」側の対応は無責任なのではないかと感じてしまいます。

年始にYahoo!のどれかのサービスがUAにGecko/2009が含まれていると使えないという話を見かけました。
一応は修正されたものの、来年もまた修正依頼をしないといけないような決着だったはずです。
これは受け売りになりますが、サービスの利用可否をUAで判別する場合は、ホワイトリストで受け入れるのではなくブラックリストで弾いて欲しいと思います。


通報する
ページトップ
 プロフィール  
引用付きで返信する  
投稿記事Posted: 2009年7月28日(火) 10:37 
> 一般的なユーザーの場合、一旦 UA を偽装設定してしまうと、その後そのサイトが対応したと
> しても、UA を元に戻す事を意識している人というのは少ないような気もします。Firefox の
> バージョンアップを行えば、自動的に更新されるのかもしれませんが。

UserAgentSwitcherでの偽装であれば、Firefoxを終了すれば、次回起動からはデフォルトのUAに戻ります。
configで直接(永久的)偽装をすれば、バージョンアップしても更新はされません。


> UAをIE7だとした場合、本当のIE7では動く機能が動かないなんてこともありそうです。

ありそうというより、実際IEにしか対応していないスクリプトなどは使えないでしょう。


通報する
ページトップ
  
引用付きで返信する  
投稿記事Posted: 2009年7月28日(火) 12:57 
オフライン
Moderator

登録日時: 2006年11月22日(水) 11:54
記事: 608
お住まい: 琵琶湖・淀川流域
試しついでに Mapion を試してみました。

こちらは Firefox 3.5 以上なら現在位置情報も利用できるようになっていて、
勿論、Minefield 3.6a1pre. でも何の問題もなくスクロール地図を利用可能。
UA 偽装なんて面倒な事をする必要は一切ありません。
現在位置情報で現在位置をセットして目的地までのドライブマップを再生することも可能でした。
( ただ現在位置情報は誤差が大きすぎるような気もしますけど )

と云う事で、Firefox ユーザは Mapion で :lol:

_________________
- Windows7 Home Premium (64bit)
- Mozilla Firefox 31.0 (32bit)
- Mozilla Nightly 34.0a1 US-En (64bit)
- Mozilla Thunderbird 24.0.3
- Twitter ID: a1works
- ChatWork ID: a1works
- Skype ID: a1_works


通報する
ページトップ
 プロフィール  
引用付きで返信する  
投稿記事Posted: 2009年7月28日(火) 23:47 
オフライン

登録日時: 2008年5月04日(日) 21:43
記事: 341
お住まい: 日本
Cai さんが書きました:
ぼてじゃこ さんが書きました:
「いつも NAVI 」回答メール さんが書きました:
誠に恐れ入りますが、現在のところスクロール地図はFirefox3.5では
正常に表示することが出来ないため、クリック地図が表示されます。

なお、スクロール地図について、Firefox3.5でも表示できるよう
出来るだけ早く対応をさせる予定ではおりますが、対応完了までに時間
がかかってしまう場合もございますこと、あらかじめご了承の程
お願いいたします。

ご不便をおかけいたしまして大変恐縮ですが、ユーザーエージェントを
変更いただくか、他のブラウザにてお試しいただけますと幸いです。


やはり、サービスの機能が Firefox3.5 には対応できていないに過ぎません。

かなりアホな応対ですねぇ。
「ユーザーエージェントを変更」で問題ないのであればサーバ側でのブラウザの判定ロジックを修正すればいい話であり、完全にあちらの怠慢です。
UA の "Firefox/x.x.x.x" の数字の部分見てるんだと思いますが、数文字書き換えれば済むでしょうに。

営利企業のコンテンツなのですから十分検証してある程度のところにくるまで「非対応」というのは当たり前ですよ。
Fx3とFx3.5は別ものなくらいいろいろ変更がされているので、検証にそれなりに時間がかかるでしょうし、これを馬鹿だの傲慢だとかアホな対応という言葉で片付けるのは非常識であると思います。

#人に馬鹿って言う方が馬鹿なんだよ by 小学生


通報する
ページトップ
 プロフィール  
引用付きで返信する  
投稿記事Posted: 2009年7月29日(水) 09:27 
オフライン
Moderator

登録日時: 2006年11月22日(水) 11:54
記事: 608
お住まい: 琵琶湖・淀川流域
どなたが賢くて、誰がアホなのかはわかりませんけど、私が賢くない事だけは確かです(笑)
ただ、「いつもNAVI」さんの対応が非常におざなりなことも又、確かなのです。まるでお役所仕事のように。

「推奨環境」で「正常には動作しない」とされていた IE8 や触れられてもいない Google Chrome (しかも dev 版) で
「スクロール地図が何の障害もなく表示されて動作しているが」と伝えると、その部分だけを削除する始末なのです。
文節の中で「シンプル地図」が代替表示されるとなっている Opera についてはそのままにして。
ところが実際には Opera 9.64 で表示されるのは「シンプル地図」ではなく「スクロール地図」です。
つまり、何一つ自分たちの眼や手で確かめもせず指摘された部分だけを書き換えると云う不誠実な対応しか行なわれていないのです。

「営利団体である以上は検証が完了するまでは非対応」と云うのは企業の論理としては理解も出来ますが、
対応していないのは「いつも NAVI」のコンテンツであるのに、「ブラウザが対応していない」と云う形に事実を歪曲して告知することが
営利団体だけには許されているとも思えません。「営利団体」と云う事を免罪符にして事実を歪曲して告知してもよいのでしょうか。

そして、いまも Firefox 3.5x でアクセスすると「User Agent Switcher」のインストールを促すヘルプに誘導され、
そのページの最後には「Firefox3.5が正規に対応するまで上記方法をご利用いただけたらと存じます。」と云う真っ赤な嘘が記述されたままです。
http://www.its-mo.com/stc/help/ff35-con ... 8%E5%B8%82


通報する
ページトップ
 プロフィール  
引用付きで返信する  
投稿記事Posted: 2009年7月30日(木) 01:52 
オフライン

登録日時: 2008年5月26日(月) 01:41
記事: 1243
お住まい: 冥府
そう云う管理者の頭の中が駄目と云うオチで如何でしょうか?
「が」では無く「に」が正しいのですから。
ブラウザでは無くコーディングが肝心・・・

_________________
*Windows 10 Red Stone2(1703/15063.138) 64bit/*GoogleJapaneseInput:MS-IME
Firefox 53.0.3:Beta 53:Developer Edition 54.0a2:Nightly 55.0a1:
Thunderbird 52.1.1:Earlybird 54.0a2:Daily 55.0a1:SeaMonkey 2.46/2.50a1:
Opera 45.0.2552.812:Google Chrome 58.0.3029.81/60.0.3100.0(Official Build)canary:
Iron 58.0.3050.0:Lunascape 6.15.1:Avant Ultimate 2017 build 5


通報する
ページトップ
 プロフィール  
引用付きで返信する  
期間内表示:  ソート  
新しいトピックを投稿する トピックへ返信する  [ 14 件の記事 ] 

All times are UTC + 9 hours


オンラインデータ

このフォーラムを閲覧中のユーザー: なし & ゲスト[1人]


トピック投稿:  可
返信投稿:  可
記事編集: 不可
記事削除: 不可
ファイル添付: 不可

検索:
ページ移動:  
Powered by MozillaZine.jp® Forum Software © phpBB Group , Almsamim WYSIWYG
Japanese translation principally by ocean