― MozillaZine.jp フォーラムは Mozilla 製品に関する情報交換の場です ―



All times are UTC + 9 hours

新しいトピックを投稿する トピックへ返信する  [ 14 件の記事 ] 
作成者 メッセージ
投稿記事Posted: 2006年1月13日(金) 13:38 
Thunderbird 1.5に更新後、毎回起動時に以下のパスワードの入力を求められます。

 ・「メールサーバーのパスワードが必要です」
  (hogehoge上のhogeのパスワードを入力してください:)
 ・「パスワードを入力してください:」
  (hogeのhogehoge用のパスワードを入力してください:)
 ・「プロンプト」
  (Software Security Deviceのマスターパスワードを入力してください。)


以前使用していた1.0.6では、最後のマスターパスワードのみ起動時に入力すればThunderbirdを使用できていました。

毎回3度もパスワードを入力するのは大変な手間です。どうにかならないでしょうか?

対策をご存じでしたら教えてください。よろしくお願いします。


通報する
ページトップ
  
引用付きで返信する  
 記事の件名:
投稿記事Posted: 2006年1月13日(金) 14:56 
オフライン
Administrator

登録日時: 2005年6月23日(木) 23:29
記事: 2520
お住まい: 東京
まずパスワードマネージャにアカウントのパスワードが保存されているか確認してみてください。
ツール->オプション->プライバシー->パスワード->保存されているパスワードを表示
「パスワードを保存しないアカウント」に入っていたらここからは削除してください。

次にパスワードを入力するときに「パスワードマネージャでこのパスワードを保存する。」にチェックが入っているか確認してください。
このチェックが入っていないとThunderbirdはパスワードを保存しないため毎回聞かれることになります。

_________________
[Desktop] Windows 10 Pro 1909 (64bit) / Intel Core i7-2600 / AMD Radeon HD 7870 / 32 GB Memory
[Laptop] Windows 10 Pro 1909 (64bit) / Intel Core i5-520M vPro / Intel HD Graphics / 8 GB Memory
[Android] Android Nougat 10.0 (arm64) / Xperia 5 SO-01M
常用環境: Firefox ベータ版 (Win64 x86-64), Thunderbird + Lightning リリース版 (Win64 x86-64)
テスト環境: Firefox (ESR, リリース版, Nightly, Win64 x86-64)

Cai/1.0 (Homo sapiens; N; Homo sapiens chemist; male; rv:0.0.3.8+)
-- いつまでたっても nightly


通報する
ページトップ
 プロフィール  
引用付きで返信する  
 記事の件名:
投稿記事Posted: 2006年1月13日(金) 15:10 
Cai様

>パスワードマネージャにアカウントのパスワードが保存されているか確認してみてください。
確認しました。以下の様に保存されていました。
 xmailbox://hoge@???.???.???.???, <指定無し>, ********


>「パスワードを保存しないアカウント」に入っていたらここからは削除してください。
ここには何も保存されていませんでした。


>次にパスワードを入力するときに「パスワードマネージャでこのパスワードを保存する。」にチェックが入っているか確認してください。
Thunderbirdを終了・再起動しましたが、パスワードの入力ウィンドウには
「パスワードマネージャでこのパスワードを保存する。」というチェックボックスはあらわれませんでした。
パスワード入力ウィンドウはどれも、パスワード入力エリア、OKボタン、キャンセルボタンのみです。


通報する
ページトップ
  
引用付きで返信する  
 記事の件名:
投稿記事Posted: 2006年1月13日(金) 15:26 
オフライン
Administrator

登録日時: 2005年6月23日(木) 23:29
記事: 2520
お住まい: 東京
thachi さんが書きました:
Cai様

>パスワードマネージャにアカウントのパスワードが保存されているか確認してみてください。
確認しました。以下の様に保存されていました。
 xmailbox://hoge@???.???.???.???, <指定無し>, ********


>「パスワードを保存しないアカウント」に入っていたらここからは削除してください。
ここには何も保存されていませんでした。


>次にパスワードを入力するときに「パスワードマネージャでこのパスワードを保存する。」にチェックが入っているか確認してください。
Thunderbirdを終了・再起動しましたが、パスワードの入力ウィンドウには
「パスワードマネージャでこのパスワードを保存する。」というチェックボックスはあらわれませんでした。
パスワード入力ウィンドウはどれも、パスワード入力エリア、OKボタン、キャンセルボタンのみです。


パスワードだけ保存されていてユーザ名が保存されていませんね。
ツール->アカウント設定->サーバ設定 で、ユーザ名が入っているか確認してみてください。
そのうえでパスワードマネージャに保存されているものを削除して、もう一度パスワードを入力してみてください。
1.5へアップデートしたときに何らかの原因で保存されている情報が壊れてしまったのかもしれません。

_________________
[Desktop] Windows 10 Pro 1909 (64bit) / Intel Core i7-2600 / AMD Radeon HD 7870 / 32 GB Memory
[Laptop] Windows 10 Pro 1909 (64bit) / Intel Core i5-520M vPro / Intel HD Graphics / 8 GB Memory
[Android] Android Nougat 10.0 (arm64) / Xperia 5 SO-01M
常用環境: Firefox ベータ版 (Win64 x86-64), Thunderbird + Lightning リリース版 (Win64 x86-64)
テスト環境: Firefox (ESR, リリース版, Nightly, Win64 x86-64)

Cai/1.0 (Homo sapiens; N; Homo sapiens chemist; male; rv:0.0.3.8+)
-- いつまでたっても nightly


通報する
ページトップ
 プロフィール  
引用付きで返信する  
 記事の件名:
投稿記事Posted: 2006年1月13日(金) 15:49 
Cai様

>ツール->アカウント設定->サーバ設定 で、ユーザ名が入っているか確認してみてください。
ユーザー名は入っていました。


>そのうえでパスワードマネージャに保存されているものを削除して
全て削除ボタンを押して削除しました。


>もう一度パスワードを入力してみてください。
Thunderbirdを終了・再起動し、最初の投稿の様に起動時にパスワードを3回入力しました。
そして、パスワードマネージャを見てみましたがユーザー名は<指定無し>のままでした。


通報する
ページトップ
  
引用付きで返信する  
 記事の件名:
投稿記事Posted: 2006年1月13日(金) 23:12 
オフライン
Administrator

登録日時: 2005年9月02日(金) 00:59
記事: 1762
thachi さんが書きました:
Thunderbirdを終了・再起動し、最初の投稿の様に起動時にパスワードを3回入力しました。
そして、パスワードマネージャを見てみましたがユーザー名は<指定無し>のままでした。

# たぶん、表題のような起動時のパスワードではないと思いますが

起動と同時にメールチェックを行う設定になっていて、初回メールチェック時にパスワードを要求してくるのでしょう。

起動時のメールチェックを行わないようにすると記憶させられるかも知れません。なぜか起動時のチェックは通常のボタン操作でのメールチェックと動作が違うような動きをします(1.0.2ぐらいのときにサーバーとの通信を観察したのですが...違うスレッドで競合していたような...)

手っ取り早いのは
 xmailbox://hoge@???.???.???.???, <指定無し>, ********
と内容を表示したファイルそのもの(表示されているのだからわかっていますね)を削除してパスワードを設定し直すという手があるかも。

また、セキュリティソフトの仕業っていうのも考えられます。ユーザーのパスワードやクレジットカード番号など特別に守らなければならないと認識しているキーストロークを許可のないアプリケーションに渡さないっていうやつです。(でも???.???.???.???にはならないはずだし、警告が出るはず)


通報する
ページトップ
 プロフィール  
引用付きで返信する  
 記事の件名:
投稿記事Posted: 2006年1月13日(金) 23:30 
オフライン
Administrator

登録日時: 2005年6月23日(木) 23:29
記事: 2520
お住まい: 東京
kiyo4_k さんが書きました:
thachi さんが書きました:
Thunderbirdを終了・再起動し、最初の投稿の様に起動時にパスワードを3回入力しました。
そして、パスワードマネージャを見てみましたがユーザー名は<指定無し>のままでした。

# たぶん、表題のような起動時のパスワードではないと思いますが

起動と同時にメールチェックを行う設定になっていて、初回メールチェック時にパスワードを要求してくるのでしょう。

起動時のメールチェックを行わないようにすると記憶させられるかも知れません。なぜか起動時のチェックは通常のボタン操作でのメールチェックと動作が違うような動きをします(1.0.2ぐらいのときにサーバーとの通信を観察したのですが...違うスレッドで競合していたような...)


僕も起動時にチェックするようにしていますが、記憶させることはできます。このへん環境依存なんでしょうか。

kiyo4_k さんが書きました:
手っ取り早いのは
 xmailbox://hoge@???.???.???.???, <指定無し>, ********
と内容を表示したファイルそのもの(表示されているのだからわかっていますね)を削除してパスワードを設定し直すという手があるかも。

また、セキュリティソフトの仕業っていうのも考えられます。ユーザーのパスワードやクレジットカード番号など特別に守らなければならないと認識しているキーストロークを許可のないアプリケーションに渡さないっていうやつです。(でも???.???.???.???にはならないはずだし、警告が出るはず)


???は伏せているのでは?削除するとしたらプロファイルフォルダのsignons.txtかxxxxxxxx.sですね。(バックアップとった上でやってください)

_________________
[Desktop] Windows 10 Pro 1909 (64bit) / Intel Core i7-2600 / AMD Radeon HD 7870 / 32 GB Memory
[Laptop] Windows 10 Pro 1909 (64bit) / Intel Core i5-520M vPro / Intel HD Graphics / 8 GB Memory
[Android] Android Nougat 10.0 (arm64) / Xperia 5 SO-01M
常用環境: Firefox ベータ版 (Win64 x86-64), Thunderbird + Lightning リリース版 (Win64 x86-64)
テスト環境: Firefox (ESR, リリース版, Nightly, Win64 x86-64)

Cai/1.0 (Homo sapiens; N; Homo sapiens chemist; male; rv:0.0.3.8+)
-- いつまでたっても nightly


通報する
ページトップ
 プロフィール  
引用付きで返信する  
 記事の件名:
投稿記事Posted: 2006年1月13日(金) 23:50 
オフライン
Administrator

登録日時: 2005年9月02日(金) 00:59
記事: 1762
Cai さんが書きました:
???は伏せているのでは?

あっと、そういうことか。パスワードは最後って言う認識だったので"********"の部分だと思ってました。
「hoge@???.???.???.???」っていうのはサーバー名がなにかのソフトのせいで置き換わっているのかな、と。


引用:
僕も起動時にチェックするようにしていますが、記憶させることはできます。このへん環境依存なんでしょうか。

いや、環境依存ってことは無いと思います。「このフォルダは使用中です」とかメッセージ出たことないですか?
微妙なタイミングの時にスレッドが複数走ってしまい、そのタイミングの悪いときにサーバーから拒否を返されることがあり、そのときにはThunderbirdでの初回のパスワードを記憶してくれません(でした < 過去形)
これは1年ぐらい前の話しです。私は起動時のメールチェックはしないように設定しています。


通報する
ページトップ
 プロフィール  
引用付きで返信する  
 記事の件名:
投稿記事Posted: 2006年1月14日(土) 00:12 
オフライン
Administrator

登録日時: 2005年6月23日(木) 23:29
記事: 2520
お住まい: 東京
kiyo4_k さんが書きました:
Cai さんが書きました:
???は伏せているのでは?

あっと、そういうことか。パスワードは最後って言う認識だったので"********"の部分だと思ってました。
「hoge@???.???.???.???」っていうのはサーバー名がなにかのソフトのせいで置き換わっているのかな、と。


いや、パスワ-ドは********の部分です。???.???.???.???の部分は普通はサ-バがきます。

パスワ-ドマネ-ジャでの表示(左からアカウント、ユ-ザ名、パスワ-ド)
mailbox://hogehoge@pop.example.com , hogehoge , foobar

なのでユ-ザ名が空白なのはおかしいな、と思ったのですが...
ん?thachiさんのはmailbox://じゃなくてxmailbox://になってますね。
ひょっとしてPOPじゃなくてIMAPなんでしょうか?
IMAPは使ってないのでさっぱりですが。

kiyo4_k さんが書きました:
Cai さんが書きました:
僕も起動時にチェックするようにしていますが、記憶させることはできます。このへん環境依存なんでしょうか。

いや、環境依存ってことは無いと思います。「このフォルダは使用中です」とかメッセージ出たことないですか?
微妙なタイミングの時にスレッドが複数走ってしまい、そのタイミングの悪いときにサーバーから拒否を返されることがあり、そのときにはThunderbirdでの初回のパスワードを記憶してくれません(でした < 過去形)
これは1年ぐらい前の話しです。私は起動時のメールチェックはしないように設定しています。


えっと、覚えがないです。
起動と同時にフォルダの最適化が始まることはよくありますが、特に問題はありません。

_________________
[Desktop] Windows 10 Pro 1909 (64bit) / Intel Core i7-2600 / AMD Radeon HD 7870 / 32 GB Memory
[Laptop] Windows 10 Pro 1909 (64bit) / Intel Core i5-520M vPro / Intel HD Graphics / 8 GB Memory
[Android] Android Nougat 10.0 (arm64) / Xperia 5 SO-01M
常用環境: Firefox ベータ版 (Win64 x86-64), Thunderbird + Lightning リリース版 (Win64 x86-64)
テスト環境: Firefox (ESR, リリース版, Nightly, Win64 x86-64)

Cai/1.0 (Homo sapiens; N; Homo sapiens chemist; male; rv:0.0.3.8+)
-- いつまでたっても nightly


通報する
ページトップ
 プロフィール  
引用付きで返信する  
 記事の件名:
投稿記事Posted: 2006年1月14日(土) 00:31 
オフライン
Administrator

登録日時: 2005年9月02日(金) 00:59
記事: 1762
Cai さんが書きました:
いや、パスワ-ドは********の部分です。???.???.???.???の部分は普通はサ-バがきます。

パスワ-ドマネ-ジャでの表示(左からアカウント、ユ-ザ名、パスワ-ド)
mailbox://hogehoge@pop.example.com , hogehoge , foobar

なのでユ-ザ名が空白なのはおかしいな、と思ったのですが...
ん?thachiさんのはmailbox://じゃなくてxmailbox://になってますね。
ひょっとしてPOPじゃなくてIMAPなんでしょうか?
IMAPは使ってないのでさっぱりですが。

あーー なるほど、サーバー名も隠したかったってことね。 (^^;)

私も現在はThunderbirdではIMAPを使用していないのでわかりません。


引用:
えっと、覚えがないです。
起動と同時にフォルダの最適化が始まることはよくありますが、特に問題はありません。

そうですか、私のところでは頻繁にダイアログが出されます。本来はマルチスレッドが許されないタイミングでマルチスレッドを発生させるバグがあるようです。(ダブルログイン防止のためのダイアログなのかな? よくわかりません)
SSL接続でこれが発生するとアウトのようです。


通報する
ページトップ
 プロフィール  
引用付きで返信する  
 記事の件名:
投稿記事Posted: 2006年1月14日(土) 01:05 
私も1.0.7から1.5にしたら、パスワード入力ダイアログの誤動作?に悩まされました。
私の場合、Thunderbird起動時ではなく、操作中にいきなり(10分毎?)パスワード入力画面が出てしまってました。
起動時のメール着信チェックOFF、メール到着チェックも登録した全アカウントについてもOFFにしているのに、です。
複数のアカウントを登録して使用していますが、パスワード入力画面が出るのは特定の1つだけ(SSL接続)。

このダイアログでパスワードを保存、にチェックを入れても、しばらくすると、またダイアログが出てしまってました。
どうやらメール到着チェックOFF設定でもメール到着チェックをしているような感じでした。

そこで、パスワードマネージャで問題が起きているアカウント1つを消してみたのですが、まだ変だったので、もう一度パスワードマネージャを開くと、同一サーバの旧アカウントが残っているのが見えたので、これも消してから再設定したら、今度は治りました。

古いアカウントデータが不完全な形でゴミ?としてどこかの設定ファイルに残っていると、1.0.7では誤動作が起きなかった場合でも、1.50では誤動作が起きる場合がある、という事なのかもしれません。
(最初はSSL接続のアカウント固有の問題?とか思ったのですが、私の場合はSSLは関係なかったみたいです。)


通報する
ページトップ
  
引用付きで返信する  
 記事の件名:
投稿記事Posted: 2006年1月14日(土) 01:19 
オフライン
Administrator

登録日時: 2005年6月23日(木) 23:29
記事: 2520
お住まい: 東京
パスワード管理がxxxxxxxx.sからsignons.txtに変わった影響でしょうか?
avairyからプロファイル移行するとおかしくなるとか。

#僕はmozilla-1.8にするときにプロファイル作り直してます。

_________________
[Desktop] Windows 10 Pro 1909 (64bit) / Intel Core i7-2600 / AMD Radeon HD 7870 / 32 GB Memory
[Laptop] Windows 10 Pro 1909 (64bit) / Intel Core i5-520M vPro / Intel HD Graphics / 8 GB Memory
[Android] Android Nougat 10.0 (arm64) / Xperia 5 SO-01M
常用環境: Firefox ベータ版 (Win64 x86-64), Thunderbird + Lightning リリース版 (Win64 x86-64)
テスト環境: Firefox (ESR, リリース版, Nightly, Win64 x86-64)

Cai/1.0 (Homo sapiens; N; Homo sapiens chemist; male; rv:0.0.3.8+)
-- いつまでたっても nightly


通報する
ページトップ
 プロフィール  
引用付きで返信する  
 記事の件名:
投稿記事Posted: 2006年1月14日(土) 15:49 
オフライン
Administrator

登録日時: 2005年9月02日(金) 00:59
記事: 1762
Cai さんが書きました:
パスワード管理がxxxxxxxx.sからsignons.txtに変わった影響でしょうか?
avairyからプロファイル移行するとおかしくなるとか。

私のところは xxxxxxxx.s になっていて、
Thunderbird本体のほうはavairyやrcや英語版最新版や日本語最新版など、バージョンは行ったり来たりしています。
それでもパスワードに関しては こういう問題は発生していません。

どのバージョンからでも、切り替えはプログラムのフォルダの消去とchromeとextensionsの削除だけで通しているのですが。


通報する
ページトップ
 プロフィール  
引用付きで返信する  
 記事の件名:
投稿記事Posted: 2006年1月16日(月) 10:26 
Cai様、kiyo4_k様、mikan様

平日の日中の仕事中のみアクセスしていますので、ご連絡が遅くなりました。


1.パスワードマネージャの設定内容
 xmailbox://hoge@???.???.???.???, <指定無し>, ********
  ・hoge@???.???.???.???(サーバ名)は内容を隠しています。
  ・********(パスワード)は内容を隠しています。

2.起動と同時にメールチェックを行う設定になっていて…(kiyo4_k様)
 起動時のチェックを外しましたが、パスワードを何度も入力しなければなりません。Thunderbird再起動後も同様です。

3.ファイルそのもの(表示されているのだからわかっていますね)を削除してパスワードを設定し直す…(kiyo4_k様)
 ファイル(xxxxxx.s)削除を削除しましたが改善はしませんでした。

4.セキュリティソフトの仕業…(kiyo4_k様)
 1.0.6では問題は無く、パターンファイルは毎日更新されていますが、セキュリティソフト自体の更新は行なっていません。

5.ひょっとしてPOPじゃなくてIMAPなんでしょうか? (Cai様)
 POPです。ちなみにアカウント設定のセキュリティ設定は「使用しない」です。また保護された認証のチェックはしていません。

6.切り替えはプログラムのフォルダの消去とchromeとextensionsの削除(kiyo4_k様)
 chromeとextensionsをリネームしてThunderbirdを起動しましたが改善しませんでした(テーマと拡張機能はデフォルトで起動しました)。起動時のチェックを外すこと等も試しましたが同様でした。


----------
何らかの設定情報がおかしくなっているようですので、プロファイルマネージャで新しくプロファイルを作成し、旧プロファイルのMail、chrome、extensionsフォルダを新プロファイルへコピーしたところ、以前と同じ設定内容でマスターパスワードのみでメール受信ができるようになりました。

現在のパスワードマネージャの設定内容は、
 mailbox://hoge@???.???.???.???, hoge, ********
となりユーザ名が正しく設定されました。また、xxxxxx.sというファイルは無く、signons.txtのファイルにパスワード情報が保存されているようです。
mailboxからxが取れました。

今回の根本原因はわからないですが、当初の目的であるマスターパスワードのみでメールの送受信ができるようになりましたので、解決したということにさせていただきます。

お忙しいところ親身に解決方法を御教授頂きましてありがとうございました。


通報する
ページトップ
  
引用付きで返信する  
期間内表示:  ソート  
新しいトピックを投稿する トピックへ返信する  [ 14 件の記事 ] 

All times are UTC + 9 hours


オンラインデータ

このフォーラムを閲覧中のユーザー: Google Feedfetcher & ゲスト[59人]


トピック投稿:  可
返信投稿:  可
記事編集: 不可
記事削除: 不可
ファイル添付: 不可

検索:
ページ移動:  
Powered by MozillaZine.jp® Forum Software © phpBB Group , Almsamim WYSIWYG
Japanese translation principally by ocean