― MozillaZine.jp フォーラムは Mozilla 製品に関する情報交換の場です ―



All times are UTC + 9 hours

新しいトピックを投稿する トピックへ返信する  [ 19 件の記事 ]  ページ移動 1, 2  次へ
作成者 メッセージ
投稿記事Posted: 2020年4月02日(木) 19:22 
オフライン

登録日時: 2020年4月02日(木) 19:09
記事: 3
thunderbirdにて返信したメールに矢印の返信マークが付きません。

受信ボックスに直接入ってきたメールについては
返信すると矢印マークが付きますが
受信ボックス配下に作成したフォルダに振り分けたメールは
返信しても返信マークが付きません。

環境はWindows10
2020/4/2付けで最新版のthunderbird

その他ためしたこととしては
・フォルダ修復
・新規プロファイル作成と再設定
・セーフモードで起動
・アドオンの無効化
メールはIMAP形式で受信しております。

知見御座いましたらご教示頂けますと幸いです。

_________________
Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/80.0.3987.149 Safari/537.36


通報する
ページトップ
 プロフィール  
引用付きで返信する  
投稿記事Posted: 2020年4月03日(金) 21:12 
オフライン

登録日時: 2013年5月19日(日) 13:46
記事: 960
ティーさん侍 さん、maji とゆ者です。


ティーさん侍 さんが書きました:
環境はWindows10
2020/4/2付けで最新版のthunderbird

質問1。

お使いの Windows10 は 32bit ですか? それとも 64bit ですか??
続いて、
「2020/4/2付けで最新版」な thunderbird のバージョンは具体的に何ですか?
そしてそれは 32bit版ですか?? それとも 64bit版ですか???


ティーさん侍 さんが書きました:
thunderbirdにて返信したメールに矢印の返信マークが付きません。
メールはIMAP形式で受信しております。

質問2。

お使いのメールサービスは何処の何ですか?


-----


手元の

Windows10(32bit) + Thunderbird (32bit) 68.6.0

でテストしてみました。

IMAP環境の 受信トレイ の中に(配下に)フォルダを作り
そこに受信済メールを1通だけ放り込み
「返信」操作をしました。
ちゃんと「矢印の返信マーク」が付きました。
その上で
他の PC の Thunderbird の IMAPアカウントで見ると
受信トレイの中に作ったフォルダにある該当のメールには
ちゃんと「矢印の返信マーク」が付いてました。
よって
この「矢印の返信マーク」は IMAPメールサーバ上のメールについているみたいです。
よってよって
ティーさん侍 さんがお困りの現象はサーバ側の問題ではないかと推測しています。


私の使ってるサーバは個人契約レンタルサーバのものですが
機能的には割と標準的な IMAPサーバぢゃないかと思ってます。

質問2に記した
ティーさん侍 さんお使いのメールサービスが何処の何か
気になってます。


-----


では。

_________________
Mozilla/5.0 (Windows NT 10.0; rv:75.0) Gecko/20100101 Firefox/75.0


通報する
ページトップ
 プロフィール  
引用付きで返信する  
投稿記事Posted: 2020年4月03日(金) 23:07 
オフライン

登録日時: 2014年2月22日(土) 00:59
記事: 1564
maji さんが書きました:
Windows10(32bit) + Thunderbird (32bit) 68.6.0

でテストしてみました。

私も試していたのですが時間かかってしまいました。環境は
 Mozilla/5.0 (Windows NT 10.0; WOW64; rv:68.0) Gecko/20100101 Thunderbird/68.6.0
および
 Mozilla/5.0 (Windows NT 10.0; WOW64; rv:60.0) Gecko/20100101 Thunderbird/60.9.1
です。

それで結果ですが、受信トレイの下、同レベルの2箇所のフォルダーにメッセージフィルターで振り分け後のメールに対して返信操作をしたところ、
  • Gmail
  • Outlook.com (Hotmail)
  • Zoho Mail
のいずれも返信マークは付きませんでした。
またThunderbird 60でも同じでした。

念のため、サーバー側機能でも振り分けてみましたが同じです。

_________________
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:74.0) Gecko/20100101 Firefox/74.0


通報する
ページトップ
 プロフィール  
引用付きで返信する  
投稿記事Posted: 2020年4月05日(日) 13:53 
オフライン

登録日時: 2013年5月19日(日) 13:46
記事: 960
EarlgreyTea さん、maji です。

【編集】 2020/4/5(日)17:00頃。末尾に「追記」しています。

-----

EarlgreyTea さんが書きました:
それで結果ですが、
受信トレイの下、同レベルの2箇所のフォルダーにメッセージフィルターで振り分け後のメールに対して返信操作をしたところ、
  • Gmail
(中略)
のいずれも返信マークは付きませんでした。

私も
Windows10(32bit) + Thunderbird (32bit) 68.6.0
の環境で
新しくテスト用のプロファイル作り Gmail のテストしたのですが、
私の手元ではちゃんと「返信マーク」が付きました。

同じ Gmail でも動作結果に差が出るみたいですね。

以前に

「 Gmailはワールドワイドな巨大システムで
  サーバが複数に分かれていて
  アカウント取得時期や場所によりサーバが異なり
  動作(仕様)もサーバ毎に微妙に違う 」

てな「噂」を聞いた記憶があります。
かなり古い時期に聞いたものなので今となっては情報ソースは不明ですが。

いま使ってる私の Gmailアカウントはかなり古いものなので
時間が取れれば 新しく Gmailアカウント取ってテストしてみます。

# 来週末、かな。

-----

ここから【編集(追記)】です( 2020/4/5(日)17:00頃 )。

上述の通り
私も自分の手元で使えるプロバイダやメールサービスを総動員して
できる範囲でテストしようとしましたが、
中にはそもそも

「受信トレイの配下に Thunderbirdではフォルダが作れない」

ものもあり
一言で imap と言っても
一筋縄ではまとめ表記できないみたいです。

なので
とりあえず私は

viewtopic.php?f=3&t=17940#p65759

に記した二つの質問への
ティーさん侍 さんの返答を待って以降の動きを考えます。

-----

では。

_________________
Mozilla/5.0 (X11; Linux i686; rv:60.0) Gecko/20100101 Firefox/60.0


通報する
ページトップ
 プロフィール  
引用付きで返信する  
投稿記事Posted: 2020年4月08日(水) 06:05 
オフライン

登録日時: 2014年2月22日(土) 00:59
記事: 1564
maji さんが書きました:
新しくテスト用のプロファイル作り Gmail のテストしたのですが、
私の手元ではちゃんと「返信マーク」が付きました。
maji さんが書きました:
いま使ってる私の Gmailアカウントはかなり古いものなので

私はGmailアカウントを3つ持っていますが、使用開始時期はたぶん 2009年、2011年、2015年です。
いずれも、Thunderbirdで返信操作した場合は、受信トレイ以外ではThunderbird/Gmail どちらでも返信マークは付きません。
Gmailで返信操作を行った場合は、Gmail/Thunderbirdどちらも返信マークが付きます。

もちろん、Thunderbirdは新規のプロファイルから設定しています。
そういったわけで、私は Thunderbird の問題もしくは仕様なのではないかと思ったのですが、どうでしょう。

_________________
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:74.0) Gecko/20100101 Firefox/74.0


通報する
ページトップ
 プロフィール  
引用付きで返信する  
投稿記事Posted: 2020年4月08日(水) 11:19 
オフライン

登録日時: 2013年5月19日(日) 13:46
記事: 960
EarlgreyTea さん、maji です。

EarlgreyTea さんが書きました:
私はGmailアカウントを3つ持っていますが、使用開始時期はたぶん 2009年、2011年、2015年です。
いずれも、Thunderbirdで返信操作した場合は、
受信トレイ以外ではThunderbird/Gmail どちらでも返信マークは付きません。
Gmailで返信操作を行った場合は、Gmail/Thunderbirdどちらも返信マークが付きます。
もちろん、Thunderbirdは新規のプロファイルから設定しています。

私の(一つしか持っていない) Gmailアカウントは 2005年の 2月に取ったものです。
念の為に

Windows10(64bit) + Thunderbird 68.6.0(64bit)

でも新規プロファイル作ってテストしましたが
結果はちゃんと返信マークが付きます。

EarlgreyTea さんが書きました:
そういったわけで、
私は Thunderbird の問題もしくは仕様なのではないかと思ったのですが、どうでしょう。

今日は時間が取れそうなので
どこかで新規に Gmail のアカウントを取ってテストしてみます。

では。

_________________
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:75.0) Gecko/20100101 Firefox/75.0


通報する
ページトップ
 プロフィール  
引用付きで返信する  
投稿記事Posted: 2020年4月08日(水) 17:42 
オフライン

登録日時: 2013年5月19日(日) 13:46
記事: 960
EarlgreyTea さん、maji です。
前投稿で記したテストやってみました。

Windows10(64bit) + Thunderbird 68.6.0(64bit)

新規に Gmailアカウントを作り、
Thunderbirdも新規プロファイルにして Gmail/IMAPアカウントを一つだけ作りました。

かつ、いつもだと
「メニューバーを表示」させたり
「HTML形式でメッセージを編集する」チェックを外したり
Gmailの場合だけ「メッセージ送信時に自動的にコピーを作成する」チェックを外すだとか
いくつか自分なりの設定をするのですが、
今回は
全く何もイジらずアカウント登録した直後そのままの状態でテストしてます。

ティーさん侍 さんが書きました:
受信ボックスに直接入ってきたメールについては
返信すると矢印マークが付きますが
受信ボックス配下に作成したフォルダに振り分けたメールは
返信しても返信マークが付きません。

下記の画像の通り
「受信トレイの配下」に test てな名前のフォルダを作り
そこに受信済メールを二通置いて
そのメール使い Thunderbird で「返信」しました。

今日(2020/4/8(水))取得したばかりの Gmailアカウントですが
正常に返信マークが付きます。

どこに差があるのかな?
そもそも、やってることが違うのかもしれない、、、
ちと不思議ですね。


添付ファイル:
コメント: majiの手元でのテスト画像。
image_gmail_test.jpg
image_gmail_test.jpg [ 137.85 KiB | 表示数: 1397 回 ]

_________________
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:75.0) Gecko/20100101 Firefox/75.0
通報する
ページトップ
 プロフィール  
引用付きで返信する  
投稿記事Posted: 2020年4月08日(水) 19:10 
オフライン

登録日時: 2020年4月02日(木) 19:09
記事: 3
majiさま
ご返信いただきありがとうございます。
確認が遅れ大変失礼致しました。

maji さんが書きました:
ティーさん侍 さんが書きました:
環境はWindows10
2020/4/2付けで最新版のthunderbird

質問1。

お使いの Windows10 は 32bit ですか? それとも 64bit ですか??
続いて、
「2020/4/2付けで最新版」な thunderbird のバージョンは具体的に何ですか?
そしてそれは 32bit版ですか?? それとも 64bit版ですか???


ティーさん侍 さんが書きました:
thunderbirdにて返信したメールに矢印の返信マークが付きません。
メールはIMAP形式で受信しております。

質問2。

お使いのメールサービスは何処の何ですか?


■質問1について
Windows10 64bit
Thunderbird 68.6.0(32ビット)

■質問2について
ロリポップサーバーです。
ロリポップサポートに本事象問い合わせたところ以下回答で、たらいまわしです( ;∀;)

>ご質問いただいた内容について、恐れ入りますがThunderbird上での
>「返信済み/転送済みマーク」が付く・つかないのフラグ情報については
>Thunderbird上で管理されている情報となるため、弊社にて事象の
>原因の調査等を行うことが難しい状況でございます。

もう自分でこまごまと原因を切り分けていくしかないのかなと。
・Outlookに設定
 → 事象発生せず。返信済みマーク付きました。
・別のPC(Windows10 64bit)のthunderbird(68.6.0 32bit)に設定
 → 事象再現

同一サーバー内の他メールアドレスは同じ環境で
IMAP受信していてもきちんと返信済みマーク付きます。

現状だとthunderbird使わずにOutlook使用で解決なのですが
出来ればthunderbirdでストレスなく使いたい次第です。。

_________________
Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/80.0.3987.149 Safari/537.36


通報する
ページトップ
 プロフィール  
引用付きで返信する  
投稿記事Posted: 2020年4月08日(水) 21:23 
オフライン

登録日時: 2014年2月22日(土) 00:59
記事: 1564
maji さんが書きました:
どこに差があるのかな?
そもそも、やってることが違うのかもしれない、、、
ちと不思議ですね。

どういうことかわかりました。
私は 受信トレイの下に「要返信」といった漢字のフォルダーを作成していました。
Gmailのラベルでいうと「INBOX/要返信」になります。
そして実ファイル名では INBOX.sbd フォルダーの中の「&iYGP1E,h-」です。

test などの半角英数(ASCII)文字のフォルダーであれば返信済みフラグ付きますが、
要返信フォルダーとかですとフラグが付かないということのようです。

ティーさん侍 さんが書きました:
出来ればthunderbirdでストレスなく使いたい次第です。。

ということなので、とりあえず漢字のフォルダー名を避けて半角英数文字のフォルダー名にしてみてはどうでしょう。

【追記】
Thunderbird の不具合といってよいと思いますが、bugzilla.mozilla.org には上がっていないようです。(メール移動でフラグが消えるとかの昔のバグなら出てきました)

_________________
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:74.0) Gecko/20100101 Firefox/74.0


通報する
ページトップ
 プロフィール  
引用付きで返信する  
投稿記事Posted: 2020年4月09日(木) 06:01 
オフライン

登録日時: 2013年5月19日(日) 13:46
記事: 960
EarlgreyTea さん、maji です。
時間が無いので結果だけ。

EarlgreyTea さんが書きました:
maji さんが書きました:
どこに差があるのかな?
そもそも、やってることが違うのかもしれない、、、
ちと不思議ですね。
どういうことかわかりました。
私は 受信トレイの下に「要返信」といった漢字のフォルダーを作成していました。
Gmailのラベルでいうと「INBOX/要返信」になります。
そして実ファイル名では INBOX.sbd フォルダーの中の「&iYGP1E,h-」です。

test などの半角英数(ASCII)文字のフォルダーであれば返信済みフラグ付きますが、
要返信フォルダーとかですとフラグが付かないということのようです。

手元で
受信トレイの配下に「test」と並列で「試験」てな名前のフォルダを作り
同様なテストしましたが、
「試験」フォルダ化なに置いたメールの返信も
ちゃんと返信マークがつきました。

とりあえず、、、。。。

_________________
Mozilla/5.0 (Windows NT 10.0; rv:68.0) Gecko/20100101 Firefox/68.0


通報する
ページトップ
 プロフィール  
引用付きで返信する  
投稿記事Posted: 2020年4月09日(木) 09:22 
オフライン

登録日時: 2020年4月02日(木) 19:09
記事: 3
EarlgreyTeaさま、majiさま

EarlgreyTea さんが書きました:
maji さんが書きました:
どこに差があるのかな?
そもそも、やってることが違うのかもしれない、、、
ちと不思議ですね。

どういうことかわかりました。
私は 受信トレイの下に「要返信」といった漢字のフォルダーを作成していました。
Gmailのラベルでいうと「INBOX/要返信」になります。
そして実ファイル名では INBOX.sbd フォルダーの中の「&iYGP1E,h-」です。

test などの半角英数(ASCII)文字のフォルダーであれば返信済みフラグ付きますが、
要返信フォルダーとかですとフラグが付かないということのようです。


受信フォルダ配下に
「testfolder」を作成してこちらに移動したメールを返信したところ返信済みマーク付きました。
この1件しかためせていないので確証はありませんが、文字コードの可能性はありそうですね。

しかし、同一メールサーバーで作成した別のアドレスでは発生していないところが気になりますね。
majiさんの環境でも発生しないようですし・・・。

本日どこかで 同一メールサーバーからテスト用のアドレスを作成してみて試してみます。

_________________
Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/80.0.3987.163 Safari/537.36


通報する
ページトップ
 プロフィール  
引用付きで返信する  
投稿記事Posted: 2020年4月10日(金) 00:57 
オフライン

登録日時: 2014年2月22日(土) 00:59
記事: 1564
どうやら Posted: 2020年4月08日(水) 21:23 は私の早合点だったようです。
フォルダーの名前が漢字であれば発生する、というわけではありませんでした。
しかし、フォルダー名が条件で起こるThunderbirdの不具合で、サーバーに依存するものではないというのが私の見解です。
仮にサーバーによる影響があったとしてもそれは副次的なものでしょう。

下記は、Gmail、Outlook.com (Hotmail)、Yahoo!メールのIMAPアカウントにて、いろいろなフォルダー名で返信済みマークが付くかを試した結果をテキストの表にしたものです。
コード:
           Gmail    Outlook.com Yahoo!メール
--------+---------+------------+------------
test        OK          OK          OK
試験        OK          OK          OK
要返信      NG          NG          NG
要試験      OK          OK          OK
あ返信      NG          NG          NG
あ返芯      OK          OK          OK
あ辺信      NG          NG          NG
信          OK          OK          OK
_信         OK          OK          OK
abc信def    OK          OK          OK
__信      NG          NG          NG
__信_    NG          NG          NG
_信_      NG          NG          NG
___      NG          NG          NG

返信操作で返信済みマークが付いた場合がOK、付かなかった場合がNGです。
ご覧のように3つのメールサービスで全く同じ結果となっています。

「特定の漢字が含まれている」という単純な条件ではなさそうです。
おそらく、フォルダー名の実体名で特定のパターンの際に不具合が発生するのでしょう。
ちなみに、IMAP4の日本語名のフォルダーの実体名は、修正UTF-7(x-imap4-modified-utf7)という形式でエンコードされています。

あとで時間があれば、実体名で何か共通パターンがないか調べてみたいと思います。

ティーさん侍 さんが書きました:
しかし、同一メールサーバーで作成した別のアドレスでは発生していないところが気になりますね。

振り分けしたフォルダー名が異なっているのではないでしょうか。
できましたら、返信済みマークが付かない症状が発生したフォルダーの名前を教えてください。

_________________
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:75.0) Gecko/20100101 Firefox/75.0


通報する
ページトップ
 プロフィール  
引用付きで返信する  
投稿記事Posted: 2020年4月10日(金) 21:17 
オフライン

登録日時: 2014年2月22日(土) 00:59
記事: 1564
EarlgreyTea さんが書きました:
あとで時間があれば、実体名で何か共通パターンがないか調べてみたいと思います。

調べてみたら共通パターンは明白でした。
x-imap4-modified-utf7変換したmboxの名前に "," 半角カンマが含まれていると返信済みマークが付かない不具合が発生するようです。

_________________
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:75.0) Gecko/20100101 Firefox/75.0


通報する
ページトップ
 プロフィール  
引用付きで返信する  
投稿記事Posted: 2020年4月11日(土) 16:42 
オフライン

登録日時: 2013年5月19日(日) 13:46
記事: 960
EarlgreyTea さん、maji です。

viewtopic.php?f=3&t=17940#p65801
EarlgreyTea さんが書きました:
Gmail、Outlook.com (Hotmail)、Yahoo!メールのIMAPアカウントにて、
いろいろなフォルダー名で返信済みマークが付くかを試した結果をテキストの表にしたものです。
コード:
           Gmail    Outlook.com Yahoo!メール
--------+---------+------------+------------
(中略)
要返信      NG          NG          NG
要試験      OK          OK          OK

私もテストしました。

Windows 10 (32bit) + Thunderbird 68.7.0(32bit)

Gmail から離れて
自分が常用してるレンタルサーバのメールサービスに戻り
IMAPサーバ上の「受信トレイ」の配下に「要返信」「要試験」の二つのフォルダを作り
返信テストしました。

結果は
EarlgreyTea さんの手とと同じで

要返信 NG
要試験 OK

でした。

念の為に、
Thunderbird ではない別のアプリ( Becky! Ver2 )で IMAP表示すると
要返信フォルダには返信マーク付いておらず
要試験フォルダでは返信マーク付いている、
つまり
「マークが見えない」のではなく
そもそも「マークが付いていない」ですね。

念の為に(2)、
別のアプリ( Becky! Ver2 )で
2つのフォルダ下のメールそれぞれ返信処理すると
両フォルダともに返信マークは付きます。
そして
Becky! で返信処理した(返信マーク付いた)後に
今度は Thunderbird で IMAP接続表示すると
ちゃんと両方のフォルダ下のメールに返信マーク付いています。

つまり NG だった「要返信」フォルダでも
他アプリで返信処理しマーク付いたものは
Thunderbirdでもちゃんとマーク表示されます。

以上、
今回の事象は、

 ・Gmail固有の問題ではなく IMAP共通の問題であり
  かつ他のアプリ(Becky!)では正常で Thunderbird固有の問題
 ・単なる 表示 の問題ではく
  Thunderbirdきち返信時に「返信マークを付けていない」

と整理できました。


viewtopic.php?f=3&t=17940#p65819
EarlgreyTea さんが書きました:
調べてみたら共通パターンは明白でした。
x-imap4-modified-utf7変換したmboxの名前に "," 半角カンマが含まれていると
返信済みマークが付かない不具合が発生するようです。

なるほど。
私の手元でも「 "," 半角カンマが含まれている」の有無を確認出来ました。


では。

_________________
Mozilla/5.0 (Windows NT 10.0; rv:68.0) Gecko/20100101 Firefox/68.0


通報する
ページトップ
 プロフィール  
引用付きで返信する  
投稿記事Posted: 2020年4月11日(土) 17:38 
オフライン

登録日時: 2014年2月22日(土) 00:59
記事: 1564
maji さんが書きました:
 ・Gmail固有の問題ではなく IMAP共通の問題であり
  かつ他のアプリ(Becky!)では正常で Thunderbird固有の問題
 ・単なる 表示 の問題ではく
  Thunderbirdきち返信時に「返信マークを付けていない」
maji さんが書きました:
私の手元でも「 "," 半角カンマが含まれている」の有無を確認出来ました。

私と同じ認識なようでよかったです。
私はたまたま「要返信」という当たりフォルダーで試していたため、最初なんとなく話が合わなかったというわけです。

ちなみに
maji さんが書きました:
つまり NG だった「要返信」フォルダでも
他アプリで返信処理しマーク付いたものは
Thunderbirdでもちゃんとマーク表示されます。
の部分は、私でいうと Posted: 2020年4月08日(水) 06:05 の
EarlgreyTea さんが書きました:
Gmailで返信操作を行った場合は、Gmail/Thunderbirdどちらも返信マークが付きます。
に該当します。

これで Thunderbird の不具合であることが確定になりました。
maji さん、バグ報告にトライしてみませんか。

_________________
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:75.0) Gecko/20100101 Firefox/75.0


通報する
ページトップ
 プロフィール  
引用付きで返信する  
期間内表示:  ソート  
新しいトピックを投稿する トピックへ返信する  [ 19 件の記事 ]  ページ移動 1, 2  次へ

All times are UTC + 9 hours


オンラインデータ

このフォーラムを閲覧中のユーザー: なし & ゲスト[20人]


トピック投稿:  可
返信投稿:  可
記事編集: 不可
記事削除: 不可
ファイル添付: 不可

検索:
ページ移動:  
Powered by MozillaZine.jp® Forum Software © phpBB Group , Almsamim WYSIWYG
Japanese translation principally by ocean