― MozillaZine.jp フォーラムは Mozilla 製品に関する情報交換の場です ―



All times are UTC + 9 hours

新しいトピックを投稿する トピックへ返信する  [ 3 件の記事 ] 
作成者 メッセージ
投稿記事Posted: 2017年2月11日(土) 12:56 
こんにちは
現在使っているThunderbirdはver.10.0.2です。

以下について教えていただけると助かります。

1. ヘルプの「Thunderbirdについて」ウィンドを表示すると「ソフトウエアの更新を確認中」と表示されますが、そこから先に進みません。更新がないということでしょうか?
2. Gmailのメールアカウントが作成できないので、OAuth 2.0に対応している38.0以降のバージョンのものを使いたいと思うのですが、その場合、新たにインストールしなければならないのでしょうか?

初歩的な質問ですみません。
よろしくお願いします。

_________________
Mozilla/5.0 (Windows NT 6.1; rv:49.0) Gecko/20100101 Firefox/49.0


通報する
ページトップ
  
引用付きで返信する  
投稿記事Posted: 2017年2月11日(土) 19:23 
※質問するときは、「フォーラムの利用に関するご案内」、とりわけ「質問するときは」に目を通し、OS の種類や Thunderbird のバージョン、アカウントの種類(IMAP か POP か)といった使用環境についての最低限の情報を書き添えることをお勧めします。

迷子のcapibara さんが書きました:
1. ヘルプの「Thunderbirdについて」ウィンドを表示すると「ソフトウエアの更新を確認中」と表示されますが、そこから先に進みません。更新がないということでしょうか?

おそらく、あまりに古すぎるバージョンなので、自動更新が効かなくなっているのではないでしょうか。

(理由)
現時点での Thunderbird のサポート内バージョンは 45.7.1 です。45.x 未満はすでにサポート外です。
Thunderbird 10.0.2 は、2012 年 2 月にリリースされたマイナーバージョンで、同年 3 月にメジャーバージョンの 11.0 がリリースされて以降はサポート外になっています。

迷子のcapibara さんが書きました:
2. Gmailのメールアカウントが作成できないので、OAuth 2.0に対応している38.0以降のバージョンのものを使いたいと思うのですが、その場合、新たにインストールしなければならないのでしょうか?

新規インストールのほうが安全でしょう。
できたとしても自動更新は避けた方がいいと思います。

(理由)
自動更新は既存のプロファイルを無条件で利用します。必ず問題が起こるとは限りませんが、これだけバージョン間の落差が大きいと、更新直後に "起動できない" 、"表示がおかしい" などの問題を起こす危険性は高いでしょう。
現在お使いのプロファイルをそのまま継続して使うのではなく、新しいバージョン用のプロファイルを新規に作成し、アカウントも作り直し、最低限必要なデータ(既存のメールデータ、アドレス帳など)だけを既存プロファイルからインポートすることをお勧めします。

なぜなら、10.0.0.2 と 38.0 以降では、プログラム本体をはじめプロファイル内の仕様や構成が大幅に変更されている部分があるからです。
メールデータやアドレス帳データなど、メールクライアントとして基盤になるデータの互換性は確保されていますが、それ以外のデータについては、新しい規格に変更されたり、問題の発覚した古い規格が廃止されたり、新機能が追加されたりしています。
通常のアップデートを順次実行していると、直近のバージョンからの変更は自動的に新しい仕様に引き継がれるようになっていますが、バージョン間の開きが大きく、その間に何段階かの変更があった要素に関しては、正常に移行できないケースが起こりえます。

10.0.0.2 に導入なさっているアドオン(拡張機能、テーマ)も、38.0 以降のバージョンでは対応しなくなっているものが多いかもしれません。新しいプロファイルには、Thunderbird のバ―ジョンに対応したアドオンを一から導入し直すほうが安全で、後のちの安定性にもプラスに働くと思います。

加えて、現在お使いのプロファイルのバックアップをしっかりとっておくことを、強くお勧めします。
万全を期したつもりで移行しても、これだけ Thunderbird の開きが大きいと不測の問題が起こる危険があるので、そのための備えはしておいたほうがいいと思います。

個々の課題については、次のサポートサイトを活用してください。
・Thunderbird - Mozilla Support Community
https://support.mozilla.org/t5/Thunderb ... derbird-ja

(補足)
特別な事情がない限り、最新の 45.x 系を使うことをお勧めします。

Thunderbird 10.0.2 をお使いの PC の OS は何ですか?
Windows の場合、Windows 7 以降なら問題はありませんが、Windows XP SP2 とか、Windows Update を適用せずに Vista の初期バージョンを使っていたような場合、OS 側の制約で標準のインストーラーが実行できないケースがあります。Thunderbird 45.0 のインストーラーの選択に気をつけてください。

セキュリティ面については、次のページをご参照ください。
(参考)
・Thunderbird セキュリティアドバイザリ
http://www.mozilla-japan.org/security/k ... rbird.html

このページにリストアップされたのは修正済みのセキュリティ脆弱性ですが、現在お使いの 10.0.2 には、11.0 以降に修正された問題の大半が残っていることにご留意ください。(新バージョンで発生して修正された脆弱性もあるので、全部とはいいませんが...。)

2017 年 3 月には、次期メジャーバージョンの Thunderbird 52.0 がリリースされる予定です。(Windows XP / Vista に対応する最後のバージョン)

とりあえず以上です。


//【お知らせ】2017 年、Firefox の大きな変化にご注意 ////////////////////////////
・Firefox の各機能サポート終了予定(2017年)について | Mozilla Japan ブログ
https://www.mozilla.jp/blog/entry/10571/
//////////////////////////////////////////////////////////////////////////////////
*ブログ記事は Firefox のものですが、ほとんどが Thunderbird にも当てはまります。

_________________
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:51.0) Gecko/20100101 Firefox/51.0


通報する
ページトップ
  
引用付きで返信する  
投稿記事Posted: 2017年2月12日(日) 14:56 
使っているOSはwindows7です。

12.0までは更新されていました。ご指摘のとおり、セキュリティ面からも最新バージョンを使ったほうが良いと思いましたので、プロファイルをバックアップしてから新規インストールで最新バージョンにすることにしました。

詳しい情報をありがとうございました。

_________________
Mozilla/5.0 (Windows NT 6.1; rv:49.0) Gecko/20100101 Firefox/49.0


通報する
ページトップ
  
引用付きで返信する  
期間内表示:  ソート  
新しいトピックを投稿する トピックへ返信する  [ 3 件の記事 ] 

All times are UTC + 9 hours


オンラインデータ

このフォーラムを閲覧中のユーザー: なし & ゲスト[18人]


トピック投稿:  可
返信投稿:  可
記事編集: 不可
記事削除: 不可
ファイル添付: 不可

検索:
ページ移動:  
Powered by MozillaZine.jp® Forum Software © phpBB Group , Almsamim WYSIWYG
Japanese translation principally by ocean