― MozillaZine.jp フォーラムは Mozilla 製品に関する情報交換の場です ―



All times are UTC + 9 hours

新しいトピックを投稿する トピックへ返信する  [ 5 件の記事 ] 
作成者 メッセージ
投稿記事Posted: 2016年1月10日(日) 02:13 
オフライン

登録日時: 2016年1月10日(日) 01:55
記事: 3
こんにちは。
最近急に「特にアドオンなど追加していない」のにFlashでフリーズします。一応設定でFlashはOFFにしてサイト閲覧できてますが
Flashのサイトなどはほぼ閲覧不可能です。ただ読み込みがすごく遅いのかフリーズしてるのかは定かではありません。
セーフモードでも同様の現象でした。
ちなみにクロームやIEで試したときは特に問題なくFlash再生されます。

できれば現在の設定「カスタマイズデザインと設定」を維持しながら再インストールしてみたいのですが(昔から使っている為複雑すぎてデザインが戻せない)
なにか良い方法があればと思いまして。

ほかの質問サイトやgoogle検索でも探しましたが半ばあきらめがちなので :lol:

--
トピックを移動しました。 -- Kuro(モデレーター)

_________________
Mozilla/5.0 (Windows NT 10.0; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0


通報する
ページトップ
 プロフィール  
引用付きで返信する  
投稿記事Posted: 2016年1月11日(月) 08:56 
オフライン
Moderator

登録日時: 2005年12月13日(火) 22:41
記事: 296
お住まい: Japan
Flash プラグイン利用ガイド
https://support.mozilla.org/ja/kb/keep- ... t-problems

Flash Player のバージョンは最新でしょうか?

Adobe社のFlash Player のバージョンを確認するページで、確認してみてください。
https://www.adobe.com/jp/software/flash/about/

今なら、20.0.0.267と表示されるはずです。
Firefox は Flash Player に脆弱性が見つかると、強制的に無効化する機能が付いています。

ちなみに、Google Chrome は Flash Player が内蔵されており、Google Chrome をアップデートすれば最新版になっています。
Internet Explorer (Windows 8.x 以上のActive X 版)は、定例の Windows Update でアップデートされます。

_________________
Mozilla/5.0 (Windows NT 6.3; WOW64; rv:46.0) Gecko/20100101 Firefox/46.0


通報する
ページトップ
 プロフィール  
引用付きで返信する  
投稿記事Posted: 2016年1月11日(月) 09:41 
オフライン

登録日時: 2016年1月10日(日) 01:55
記事: 3
Flash Player のバージョンは最新です。
アーカイブ版 Flash Player「旧バージョン数種類」をDLして試したりもしました。
アンインストール→再インストールも試しましたが結果は変わらずでした。

試したことと言えば上記と
・ProfilesをバックアップしてMozilla関連の全てをアンインストール&削除してからの再インストール→バックアップを戻す。
ちなみにクリーンな再インストールをしたあと「バックアップを戻さず」も同様の現象が発生しています。

OSはwindows10です。
現象が起こりだした直前にインストールしているものはiTunes位です。もちろんこれもアンインストールして試しています。
よろしくお願いします。

_________________
Mozilla/5.0 (Windows NT 10.0; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0


通報する
ページトップ
 プロフィール  
引用付きで返信する  
投稿記事Posted: 2016年1月14日(木) 20:41 
※質問するときは、「フォーラムの利用に関するご案内」、とりわけ「質問するときは」に目を通し、OS の種類や Firefox のバージョンといった使用環境についての最低限の情報を書き添えることをお勧めします。

横から失礼します。

投稿時の User Agent を拝見すると Firefox 45.0 (32bit) をお使いのように見受けられますが、ご質問の症状が出ているのは Windows 10 + Firefox 45.0 の環境でしょうか?
もしそうなら、次の点に注意してください。

ご承知のように、現時点で Firefox 45.0a2 は aurora チャンネルの開発版です。同時点での正式リリース版である 43.0 系との顕著な違いは、マルチプロセス機能が既定で有効になっていることでしょうか。

Firefox 45.0 は次期 ESR 版候補でもあるので、正式リリース版で日常作業をする合間に、Nightly チャンネルのころからちまちまと試用してきました(on Windows 7 / 8)。

その経験からいえば、Firefox 45.0a2 を初期状態で使った時、HTML5 でのマルチメディア再生はとくに違和感なく動作してくれますが、Flash Player プラグインを使った Flash コンテンツの再生はまだ不安定な場面が多いように感じています。
とくに開発版は更新頻度が高いですし、Flash Player もしばしば緊急のセキュリティ更新などが入って来るので、両者の組み合わせによっては、比較的安定して動作してくれるときもあれば、プラグインを使うと高確率でハングアップするときもあります。
ささやかな試用経験の範囲では、マルチプロセスを無効化すれば正式リリース版と大差なく Flash Player プラグインが動作してくれる、とは感じています。

ただ開発版の趣旨としては、マルチプロセスのような新機能をテストし、そのフィードバックを得て、いっそう安定した機能に磨き上げることを目的としているチャンネルなので、正式リリース版のような一般用途で使うために、開発版のテスト対象であるマルチプロセス機能を無効化して使うのは本末転倒であり、あまり行儀のいいことではありません。
Flash コンテンツを含めたマルチメディアの一般的な利用を主目的とするなら、正式リリース版を使うことをお勧めします。
一方、テスト目的で開発版を使っていて、Flash Player の動作不良を報告したいという話なら、Bugzilla に報告するなり、既出の報告にコメントを付けたほうがいいと思います。

(補足)
本件の事案の解決策ではありませんが、プラグインがからむ問題の点検に関する注意点として......。
SETA さんが書きました:
・ProfilesをバックアップしてMozilla関連の全てをアンインストール&削除してからの再インストール→バックアップを戻す。
ちなみにクリーンな再インストールをしたあと「バックアップを戻さず」も同様の現象が発生しています。

新しいプロファイルを作成し、既存のプロファイルから一切のデータをコピーしない素の状態でテストしても、問題の現象が発生したということですね。

ご存知のように、拡張機能やテーマが Firefox 内にインストールされ、Firefox というベースの上でだけ動作するのに比べ、プラグインはシステムにインストールされる独立したプログラムであり、Firefox だけでなく他のブラウザとも連携して動作することができます。

一般的には、まっさらなプロファイルを作っても、プラグインがシステムにインストールされていると、それは自動的に Firefox に認識されます。
64bit 版 Windows でも、使っている Firefox が 32bit 版なら、利用可能な既存のプラグインの種類が多いため、ユーザー環境に存在するプラグインの数と種類によっては、Firefox に読み込まれたプラグイン同士がコンフリクトを起こす可能性はありえます。
この点を確認するには、アドオンマネージャーのプラグインパネルで、Flash Player 以外のプラグインを明示的に無効化し、Flash プラグインだけが動作するようにしてから、Flash コンテンツの再生をテストしてみてください。

とりあえず以上です。的外れな話だったらすみません。

_________________
Mozilla/5.0 (Windows NT 6.2; WOW64; rv:43.0) Gecko/20100101 Firefox/43.0


通報する
ページトップ
  
引用付きで返信する  
投稿記事Posted: 2016年1月15日(金) 03:56 
オフライン

登録日時: 2016年1月10日(日) 01:55
記事: 3
ご指摘通りのWindows 10 + Firefox developer edition 45.0xx の環境です。WEB開発ツールの利用目的で使用していました。
Flashのクラッシュに関しては今回、時間はかかりましたがOSのクリーンインストールで元の環境まで戻してなんとか治ってくれました。
同じ現象が再発しないところを見てもWindows7から10へのアップグレードやその他ソフトのアンインストールなどが原因でWindowsのレジストリになにか問題があった可能性が高いと思っています、
ちなみに元の環境で使っていたAdobe Flash Professionalなどは現在Flashを使う機会が減った事によりまだインストールしていません。
クリーンインストール前に自作のFlashをデバッグ再生や出力してみてブラウザチェックもしましたが
特に問題なく動いていました、ただFirefox(どのバージョンでも)では再生できない(ものすごく遅延して少しずつ動く)という現象は健在でした。(元々は普通に動いてました)
この原因は結局わからなかったので怏々ですが上記の様に問題は解決致しました。
いろいろとありがとうございました。 P. S. 一応フィードバックは送っておきました :)

_________________
Mozilla/5.0 (Windows NT 10.0; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0


通報する
ページトップ
 プロフィール  
引用付きで返信する  
期間内表示:  ソート  
新しいトピックを投稿する トピックへ返信する  [ 5 件の記事 ] 

All times are UTC + 9 hours


オンラインデータ

このフォーラムを閲覧中のユーザー: Google Feedfetcher & ゲスト[6人]


トピック投稿:  可
返信投稿:  可
記事編集: 不可
記事削除: 不可
ファイル添付: 不可

検索:
ページ移動:  
Powered by MozillaZine.jp® Forum Software © phpBB Group , Almsamim WYSIWYG
Japanese translation principally by ocean