― MozillaZine.jp フォーラムは Mozilla 製品に関する情報交換の場です ―



All times are UTC + 9 hours

新しいトピックを投稿する トピックへ返信する  [ 8 件の記事 ] 
作成者 メッセージ
投稿記事Posted: 2015年2月23日(月) 10:19 
失礼します。
下記現象について、どなたか対策をご存知ではないでしょうか。

【バージョン】
Firefox 35.0.1(投稿時点での最新版)+Windows7 Professional SP1(32bit)

【現象】
「file://」でのネットワークドライブリンクが正常に開けない
【詳細】
「file://HOST名/...」へのリンクをプレーンなHTMLに記述して公開しているが
 Firefoxでは「file:///...」となってしまい(HOST名が抜ける)クリックしても開けない
 ・マウスオーバーでのステータスバー表示の時点で「file:///...」(=不具合)
 ・Firefoxから「ページのソースを表示」で確認した限りでは「file://HOST名/...」(=正常)
 ・User.jsにて当該ドメインの「file://」の有効化を設定しても改善なし
 ・IE(各バージョン)では「file://HOST名/...」として正しく認識され、Windows共有フォルダが開く


当該フォルダをHTTP公開すれば済む話かもしれませんが、事情がありこのような仕様になっています。
なんとかこのままでFirefox対応できれば、と思い、問合せます。

本件、どなたかご存知でしたらお力添えください。よろしくお願いいたします。

_________________
Mozilla/5.0 (Windows NT 6.1; rv:35.0) Gecko/20100101 Firefox/35.0


通報する
ページトップ
  
引用付きで返信する  
投稿記事Posted: 2015年2月23日(月) 12:27 
オフライン

登録日時: 2013年12月26日(木) 09:33
記事: 686
お住まい: 太陽系、地球、日本、ふてニャン県
Tooru Sanami さんが書きました:
【現象】「file://」でのネットワークドライブリンクが正常に開けない
【詳細】
「file://HOST名/...」へのリンクをプレーンなHTMLに記述して公開しているが
 Firefoxでは「file:///...」となってしまい(HOST名が抜ける)クリックしても開けない
 ・IE(各バージョン)では「file://HOST名/...」として正しく認識され、Windows共有フォルダが開く

これは、Firefoxのバージョンを上げたら問題が起こった、ということですか?
それともIEでは開ける、既存のHTML,の既存のfile://HOST名/...のリンクが、初めて使ったFirefoxで開けなかった、ということですか?
後者だとすると、¥¥server¥sharedresource¥dir¥file.extといったUNCの時、
Mozillaファミリーだと、file:// + ////server + /shareedresurce/dir/file.ext のように、¥を/で置き換えるとき、先頭では余分に/が要る、といった話のように記憶しているのだが。
/ ⇒¥にしたあと、¥がエスケープ記号なので¥¥で¥を一つ食べてしまう、といったことに思えます。

マウントしてあるUNC名のファイルをFirefoxにドラッグして開き、それをブックマークに登録してみると、Firefoxにおけるfile:URLがわかります。

[追記]
やっぱりもじら組フォーラムにありました。
http://forum.mozilla.gr.jp/cbbs.cgi?mode=al2&namber=7286&KLOG=49
[/追記]


通報する
ページトップ
 プロフィール  
引用付きで返信する  
投稿記事Posted: 2015年2月23日(月) 16:35 
オフライン

登録日時: 2013年12月26日(木) 09:33
記事: 686
お住まい: 太陽系、地球、日本、ふてニャン県
この現象自体は昔からあって、イントラネットでは常に問題になることだから、アドオンでもあるかな、と思って、「file url unc path firefox ie」でググってみたら、https://bugzilla.mozilla.org/show_bug.cgi?id=66194がヒットしてきた。
以下のように書いてあります。
> file://///syntax/does/not/work/for/me (5つの/)
> in Firefox 1.5.0.3 on the exact same link that works in IE 6.0.
IEが、サーバー名の前の¥は¥¥とエスケープした形にして「¥¥¥¥サーバー名」とし、それから¥を/にしてfile:// URLにする、というのもサポートしているということなのかな?

[追記]http://stackoverflow.com/questions/811570/how-do-i-make-a-file-hyperlink-that-works-in-both-ie-and-firefox
というのもあって、こちらでも、file://///company.org/ProjectA/StatsReport(5つの/)が、IEではOKなのにFirefoxではダメ、といっている。
一体、いくつの/が正しいんでしょう?(^^)
IEは、file:// URLの時、C:¥ABC¥DEF¥GHI¥...は、URL用の完全なフルパスは、¥C:¥ABC¥DEF¥GHI¥...として、
file:// + host==Null + /C:/ABC/DEF/GHI/...としているようで、file:// + Null + / + C:/ABC/DEF/GHI/...という形になり。
¥¥Server¥ABC¥DEF¥... は、file:// + Null + / + //Server/ABC/DEF/... になる、ということのようだが...
で、 Bug 66194でも、「file:// Correct URLs w/ UNC have *5* slashes」だから正しくせよ、といっている。
[/追記]


通報する
ページトップ
 プロフィール  
引用付きで返信する  
投稿記事Posted: 2015年2月25日(水) 17:33 
皆様
お力添えありがとうございます。エスケープシーケンスの解釈違いということでしょうか。
試してみたところ、IE8(互換表示OFF)でも「file://///(HOST名)」でローカルファイルが開けることが確認できました。
未だに「file://~」でやってきたことのほうが、時代遅れだったかもしれません(汗。

お力添え、大変ありがとうございました。

_________________
Mozilla/5.0 (Windows NT 6.1; rv:35.0) Gecko/20100101 Firefox/35.0


通報する
ページトップ
  
引用付きで返信する  
投稿記事Posted: 2015年2月25日(水) 17:50 
……うまくいったかと思ったのですが、もう一段罠がありました。

・「file://///~」を直打ち →FireFox内でディレクトリ一覧が開く
・リンクとして「file://///~」をクリック →無反応
ASPやスクリプト、CSSの効果を除外するため、ベタのHTMLに当該リンクを設置して試してみましたが、結果は同じでした。

……ということで、あと一歩、というところです。
FireFoxが「file://///~」を解釈し、ローカルフォルダを開くことができる、ということは間違いないので、
今度はセキュリティ関係などを調べてみます。

_________________
Mozilla/5.0 (Windows NT 6.1; rv:35.0) Gecko/20100101 Firefox/35.0


通報する
ページトップ
  
引用付きで返信する  
投稿記事Posted: 2015年2月25日(水) 18:29 
オフライン

登録日時: 2013年12月26日(木) 09:33
記事: 686
お住まい: 太陽系、地球、日本、ふてニャン県
Tooru Sanami さんが書きました:
……うまくいったかと思ったのですが、もう一段罠がありました。
・「file://///~」を直打ち →FireFox内でディレクトリ一覧が開く
・リンクとして「file://///~」をクリック →無反応

URLをURLバーで直打ち、だと、HTML内のURLではなくて、UIでの話だから、日本語のファイル名を直接書いても、Windows環境だし、Shift_JISをUnicodeに、とかが動きますが、
HTML内のURLは、あくまでもHTML内のURLですから、日本語のファイル名は、きちんとエスケープしないとダメですよ。
ちゃんと、HTMLにおける形式のURIを、A HREFに書いていますか?
・Firefoで、「file://///~」を直打ち → FireFox内でディレクトリ一覧が開く、
で表示されてるページは、HTMLで表現されていますから、個々のファイルへのリンクは、HTMLの仕様に従っているはずです。


通報する
ページトップ
 プロフィール  
引用付きで返信する  
投稿記事Posted: 2015年12月14日(月) 19:28 
私のところでも発生しています。

WADA さんが書きました:
Tooru Sanami さんが書きました:
【現象】「file://」でのネットワークドライブリンクが正常に開けない
【詳細】
「file://HOST名/...」へのリンクをプレーンなHTMLに記述して公開しているが
 Firefoxでは「file:///...」となってしまい(HOST名が抜ける)クリックしても開けない
 ・IE(各バージョン)では「file://HOST名/...」として正しく認識され、Windows共有フォルダが開く


とあるように"HOST名"部分が抜けてしまうという現象が、いつのバージョンからか発生するようです。
以前はIE TAG+ というアドオンで何の問題もなく開けていたのですが、今は”ホスト名"部分が削除されてしまうためどうしようもありません。
ソースを表示させると見えるのですが、マウスを重ねた時に表示されるアドレスからは削除されている状態です。

_________________
Mozilla/5.0 (Windows NT 6.1; rv:42.0) Gecko/20100101 Firefox/42.0


通報する
ページトップ
  
引用付きで返信する  
投稿記事Posted: 2019年4月17日(水) 09:56 
オフライン

登録日時: 2019年4月17日(水) 09:54
記事: 1
同じ問題で困っていたので、userscriptを作成しました。
https://greasyfork.org/ja/scripts/38194 ... ert-for-ff

_________________
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0


通報する
ページトップ
 プロフィール  
引用付きで返信する  
期間内表示:  ソート  
新しいトピックを投稿する トピックへ返信する  [ 8 件の記事 ] 

All times are UTC + 9 hours


オンラインデータ

このフォーラムを閲覧中のユーザー: なし & ゲスト[2人]


トピック投稿:  可
返信投稿:  可
記事編集: 不可
記事削除: 不可
ファイル添付: 不可

検索:
ページ移動:  
Powered by MozillaZine.jp® Forum Software © phpBB Group , Almsamim WYSIWYG
Japanese translation principally by ocean