― MozillaZine.jp フォーラムは Mozilla 製品に関する情報交換の場です ―



All times are UTC + 9 hours

新しいトピックを投稿する このトピックは閉鎖されているため、編集・返信することはできません  [ 9 件の記事 ] 
作成者 メッセージ
投稿記事Posted: 2008年9月04日(木) 11:50 
MinimizeToTrayのインストールについて質問させてください。

PCの初期化(OS再インストール)を行ったため、Thunderbirdを新規に入れなおし、掲題のアドオンをインストールしたところ以下メッセージが出力され、インストールに失敗します。
対処方法等を教えていただけないでしょうか。よろしくお願いします。
※PC初期化前は問題なくインストールできており使用していました。ただし、PC初期化前のThunderbird,MinimizeToTrayの正確なバージョン等は把握できていません。

**出力されたメッセージ**
MinimizeToTray 0.0.1.2006102615+はThunderbird2.0.0.16に対応していないため、インストールできませんでした。Minimize To Tray 0.0.1.2006102615+が動作するのはThunderbirdのバージョン1.0+から2.0a1までです。

**環境**
OS:WindowsXP.SP2
Tunderbird:2.0.0.16
MinimizeToTray 0.0.1.2006102615+

以上よろしくお願いします。


通報する
ページトップ
  
引用付きで返信する  
投稿記事Posted: 2008年9月04日(木) 13:47 
オフライン
Administrator

登録日時: 2006年10月25日(水) 18:00
記事: 2030
お住まい: USA
Windows XP Pro SP2 の Thunderbird 2.0.0.16 に MinimizeToTray 0.0.1.2006102615+ をインストールしてみましたが、当方では問題なくできましたよ。

アドオンマネージャから現在インストールしている MinimizeToTray をアンインストールしてから、Mozilla Thunderbird Add-ons より MinimizeToTray 0.0.1.2006102615+ をダウンロードして、もう一度インストールし直してみてください。


通報する
ページトップ
 プロフィール  
引用付きで返信する  
投稿記事Posted: 2008年9月04日(木) 14:37 
早速の返信ありがとうございます。

確かに他の方の投稿でも同環境(XP.SP2+thunderbird2.0.0.16)で問題なく使われているようでしたし、そもそもPC初期化前は私も使えていた(はず)ので???状態です。

なお、今回の事象ですが、PC初期化後(ディスク完全初期化後のOS、Thunderbird再インストール)MinimizeToTrayはインストールすらできなくなってしまったので、現在アドオン画面にMinimizeToTrayは表示されていません。

また当方で試してみたこととしてはThunderbird自体を古いものにダウングレードしてみました。2.0.0.14では事象は変わりませんでしたが、1.x(1.xで一番新しい版)ではMinimizeToTrayが正常にインストールでき、その後1.X=>2.0.0.16にアップグレードした段階で、無効になってしまいました。(無効になったので削除しました)
ファイル自体が破壊されている可能性もあるかと思い、MinimizeToTrayを再度ダウンロードして試してみましたが事象は変わりませんでした。


通報する
ページトップ
  
引用付きで返信する  
投稿記事Posted: 2008年9月04日(木) 15:55 
オフライン
Administrator

登録日時: 2006年10月25日(水) 18:00
記事: 2030
お住まい: USA
kuro38 さんが書きました:
Thunderbird自体を古いものにダウングレードしてみました。2.0.0.14では事象は変わりませんでしたが、1.x(1.xで一番新しい版)ではMinimizeToTrayが正常にインストールでき、その後1.X=>2.0.0.16にアップグレードした段階で、無効になってしまいました。(無効になったので削除しました)

現在のプロファイルは Thunderbird 1.x から引き継いだものですか?

この問題では関係ないような気がしますが、ツール→オプションの詳細タブから『一般』の[設定エディタ]で フィルタ欄に xpinstall.enabled と入力して、値が true になっているでしょうか?

もう一つ、新規プロファイルを作り、とりあえずダミーアカウントで設定して、そこにインストールするとどうなりますか?


通報する
ページトップ
 プロフィール  
引用付きで返信する  
投稿記事Posted: 2008年9月04日(木) 16:25 
返信ありがとうございます。

新規プロファイルを作成して、そこでインストールを実施してみましたが事象は変わりませんでした。
また”xpinstall.enabled”の値 はtrueでした。

プロファイルですがThunderbird 1.xから引き継いだものではありません。
今回新規にTunderbird2.0.0.16をインストールし、設定等すべて手動でやりなおしています。
※PC初期化前の旧環境からはメールそのものを含め、移行してきたデータはありません。


通報する
ページトップ
  
引用付きで返信する  
投稿記事Posted: 2008年9月04日(木) 18:56 
オフライン
Administrator

登録日時: 2006年10月25日(水) 18:00
記事: 2030
お住まい: USA
kuro38 さんが書きました:
新規プロファイルを作成して、そこでインストールを実施してみましたが事象は変わりませんでした。
また”xpinstall.enabled”の値 はtrueでした。

プロファイルですがThunderbird 1.xから引き継いだものではありません。
今回新規にTunderbird2.0.0.16をインストールし、設定等すべて手動でやりなおしています。
※PC初期化前の旧環境からはメールそのものを含め、移行してきたデータはありません。

新規プロファイルも変わりありませんか…
MinimizeToTray 以外のアドオン、例えばスペルチェック辞書のEnglish (US)等はインストール可能でしょうか?

オフトピですけど、
MinimizeToTray 0.0.1.2006102615+ の install.rdf を確認したら、Thunderbird の max version が 2.0a1 となっていますね。
これだと最初のスレッドで書いていらっしゃる
kuro38 さんが書きました:
**出力されたメッセージ**
MinimizeToTray 0.0.1.2006102615+はThunderbird2.0.0.16に対応していないため、インストールできませんでした。Minimize To Tray 0.0.1.2006102615+が動作するのはThunderbirdのバージョン1.0+から2.0a1までです。
が表示されるのも分かりますが、なぜ私の方ではインストールできるのかな??
en-US 版を使用しているから…なんて関係ないでしょうし:?


通報する
ページトップ
 プロフィール  
引用付きで返信する  
投稿記事Posted: 2008年9月05日(金) 10:09 
返信ありがとうございます。

教えていただいたスペルチェック辞書は問題なくインストールできました。
その他にもいくつか別のアドオンで試してみましたが、正常にインストールできます。
※入れてみたもの:Lightning0.8、Minimize To Tray Enhancer0.7.5.3

Lightningは対応バージョンが~2.0.0.*でMinimizeToTrayと似た条件でしたが問題なしです。

Thunderbird本体側の問題なのかMinimizeToTray側の問題なのか分かりませんがThunderbird再インストールを考えてみたほうがいいのでしょうか?


通報する
ページトップ
  
引用付きで返信する  
投稿記事Posted: 2008年9月05日(金) 10:54 
オフライン
Administrator

登録日時: 2006年10月25日(水) 18:00
記事: 2030
お住まい: USA
kuro38 さんが書きました:
Thunderbird再インストールを考えてみたほうがいいのでしょうか?

他の拡張機能がインストールできるのでしたら、Thunderbird 自体に問題はないと思います。

これ、ダメ元ということで試してみてください。

  1. ウェブブラウザ (Firefox をお勧めします)で MinimizeToTray 0.0.1.2006102615+ のダウンロードページを開きます。
  2. Thunderbird のアドオンマネージャを表示します。
  3. MinimizeToTray 0.0.1.2006102615+ ダウンロードページの「今すぐダウンロード (Windows)」ボタンをドラッグして、Thunderbird のアドオンマネージャのウィンドウにドロップします。

上記操作で Thunderbird に xpi を直接インストールできるはずです。
これでインストールできるか試してみてください。


通報する
ページトップ
 プロフィール  
引用付きで返信する  
投稿記事Posted: 2008年9月05日(金) 11:26 
返信ありがとうございます。

教えていただいた方法でうまくインストールできました。
機能的にも問題なく動作しているようです。

的確なアドバイス、ありがとうございました。


通報する
ページトップ
  
引用付きで返信する  
期間内表示:  ソート  
新しいトピックを投稿する このトピックは閉鎖されているため、編集・返信することはできません  [ 9 件の記事 ] 

All times are UTC + 9 hours


オンラインデータ

このフォーラムを閲覧中のユーザー: なし & ゲスト[3人]


トピック投稿:  可
返信投稿:  可
記事編集: 不可
記事削除: 不可
ファイル添付: 不可

検索:
ページ移動:  
Powered by MozillaZine.jp® Forum Software © phpBB Group , Almsamim WYSIWYG
Japanese translation principally by ocean