― MozillaZine.jp フォーラムは Mozilla 製品に関する情報交換の場です ―



All times are UTC + 9 hours

返信する
ユーザー名:
件名:
オプション:
BBCode: ON
[img]: ON
[flash]: OFF
[url]: ON
スマイリー: ON
BBCode を無効にする
スマイリーを無効にする
URL を自動的にパースしない
ユーザエージェントを表示する
認証コード
KCaptcha by Nikita_Sp
   

トピックのレビュー - 開発者ツールの「ページから要素を選択」の動きがおかしい
作成者 メッセージ
  記事の件名:  Re: 開発者ツールの「ページから要素を選択」の動きがおかしい  引用付きで返信する
EarlgreyTea 様、ご検証くださりありがとうございます。

EarlgreyTea さんが書きました:
https://forums.mozillazine.jp/viewtopic.php?f=2&t=16715 に引き続き、Windows 7いじりにネットカフェに行ってきましたよ。

あーちゃ さんが書きました:
その際、開発者ツールを使用するのですが、ページ内の要素を確認しようと要素選択を行うと
要素の選択箇所が正常な動作である水色から濃いグレーになって、まともに要素選択ができなくなってしまいます。
これと同様な現象を確認できました。
開発ツールのインスペクターを開き、ノードピッカー(要素を選択アイコン)をクリックした状態でマウスポインタをページ上に持っていくと、グレーの網掛けになってしまうというものです。
この現象が起きるのは Firefox 54かつマルチプロセス無効の場合に限られました。マルチプロセス有効では正常に動作し、また、55.0b10 や 56.0a1でも問題ありませんでした。

ということで、Web制作をやっておられるということですし、Developer Edition を試してみてはいかがでしょう。
https://www.mozilla.org/ja/firefox/channel/desktop/

[追記]
Windows 10 でも、マルチプロセス無効のFirefox 54にて発生しました。


マルチプロセスを有効にしたところ、問題の症状が改善されたようです。
あまりマルチプロセスに気を使っていなかったため、そもそも無効になっていたことすら気づいておりませんでした。
私の環境の場合、いくつかのアドオンがマルチプロセス有効化の邪魔をしていたようです。

Developer Edition もかつては使用していたのですが、β版先行体験仕様になるということを耳にし、
このFirefoxをメインで使用することにした次第です。

おかげ様で、安心して使用し続けることができそうです。
この度は本当にありがとうございました。
投稿記事 Posted: 2017年7月24日(月) 09:31
  記事の件名:  Re: 開発者ツールの「ページから要素を選択」の動きがおかしい  引用付きで返信する
viewtopic.php?f=2&t=16715 に引き続き、Windows 7いじりにネットカフェに行ってきましたよ。

あーちゃ さんが書きました:
その際、開発者ツールを使用するのですが、ページ内の要素を確認しようと要素選択を行うと
要素の選択箇所が正常な動作である水色から濃いグレーになって、まともに要素選択ができなくなってしまいます。
これと同様な現象を確認できました。
開発ツールのインスペクターを開き、ノードピッカー(要素を選択アイコン)をクリックした状態でマウスポインタをページ上に持っていくと、グレーの網掛けになってしまうというものです。
この現象が起きるのは Firefox 54かつマルチプロセス無効の場合に限られました。マルチプロセス有効では正常に動作し、また、55.0b10 や 56.0a1でも問題ありませんでした。

ということで、Web制作をやっておられるということですし、Developer Edition を試してみてはいかがでしょう。
https://www.mozilla.org/ja/firefox/channel/desktop/

[追記]
Windows 10 でも、マルチプロセス無効のFirefox 54にて発生しました。


添付ファイル:
InspectorNG.png
InspectorNG.png [ 247.1 KiB | 表示数: 2549 回 ]
投稿記事 Posted: 2017年7月21日(金) 19:51
  記事の件名:  Re: 開発者ツールの「ページから要素を選択」の動きがおかしい  引用付きで返信する
pal さんが書きました:
今回の現象以外にも思わぬ不具合が出る恐れがありますので、プロファイルは作り直すのが無難です。
ただし、それで今回の現象がなくなるかは保証できませんが。


pal 様、ご意見ありがとうございます。

思い切って、以下のことを試してみたのですが、やはり症状の改善には至りませんでした。
  • Firefox のリフレッシュ
  • プロファイルの削除→新規作成
  • プロファイルの削除→新規作成→再インストール
  • セーフモード起動
やはり、しばらくは 53.x を使用するしかないようです...。
引き続き、情報をお待ちしております。
投稿記事 Posted: 2017年7月21日(金) 09:58
  記事の件名:  Re: 開発者ツールの「ページから要素を選択」の動きがおかしい  引用付きで返信する
解決法ではありません。
悪しからず。



「ユーザープロファイルの初期化までは行っていない」ということだと、現状、プロファイルはひとつでしょうか?
そのひとつで54、あるいは54.0.1を利用し、53に戻り、さらに54.0.1に戻ったというところでしょうか?
このようにひとつのプロファイルでバージョンを行ったり来たりすることは、不要な不具合を誘発する原因となります。

今回の現象以外にも思わぬ不具合が出る恐れがありますので、プロファイルは作り直すのが無難です。
ただし、それで今回の現象がなくなるかは保証できませんが。
投稿記事 Posted: 2017年7月20日(木) 21:40
  記事の件名:  Re: 開発者ツールの「ページから要素を選択」の動きがおかしい  引用付きで返信する
連投失礼いたします。
試しにFirefoxを54.0.1にあげたら症状が簡単に再現できましたので、FAST PIC というWebサービスに画像をあげてみました。

正常な状態:
https://www.fastpic.jp/viewer.php?file=0721817890.jpg

異常な状態:
https://www.fastpic.jp/viewer.php?file=3361362369.jpg


上のリンク先画像が正常で、この状態であれば問題なく要素の選択が可能です。
下のリンク先画像が問題で、こうなってしまうと要素の選択が思うように出来なくなります。
ただし、レスポンシブモードに切り替えするなどの画面の更新を行うと、一時的に上の状態に回復します。

左記の投稿で漏れてしまった部分についてです。
使用している環境ですが、Windows7Proの32ビットになります。
また、アンインストール→再インストールでも症状の改善は出来ませんでした。
ユーザープロファイルの初期化までは行っていないので試す価値はあるのかもしれませんが、
このままの改善方法があればと思う次第です。
投稿記事 Posted: 2017年7月20日(木) 19:19
  記事の件名:  開発者ツールの「ページから要素を選択」の動きがおかしい  引用付きで返信する
FireFox 54.0.1 (32ビット) を使用してWebの制作をしております。
その際、開発者ツールを使用するのですが、ページ内の要素を確認しようと要素選択を行うと
要素の選択箇所が正常な動作である水色から濃いグレーになって、まともに要素選択ができなくなってしまいます。
この症状が出るようになったのは バージョン 54.0.0 からなのですが、
54.0.1 でも症状が出続けている状況で、仕方なくバージョンを53系に落として使用しています。

この症状そのものが不具合なのか仕様なのかもよく分からないのですが、
改善に向けてどのようなことができるのか、情報をお寄せ頂きたく投稿させて頂きました。
よろしくお願いいたします。
投稿記事 Posted: 2017年7月20日(木) 15:47

All times are UTC + 9 hours


ページ移動:  
cron
Powered by MozillaZine.jp® Forum Software © phpBB Group , Almsamim WYSIWYG
Japanese translation principally by ocean