― MozillaZine.jp フォーラムは Mozilla 製品に関する情報交換の場です ―



All times are UTC + 9 hours

新しいトピックを投稿する このトピックは閉鎖されているため、編集・返信することはできません  [ 7 件の記事 ] 
作成者 メッセージ
投稿記事Posted: 2013年2月20日(水) 12:41 
オフライン

登録日時: 2013年1月31日(木) 15:34
記事: 3
今回はじめて投稿です、宜しくお願いします。

linuxでfirefoxを使っています、firefox-17までは正常に使えていたのですが、firefox-18以降以下のエラーで起動できなくなって
しまいました。

XPCOMGlueLoad error for file firefox-18.0/libxpcom.so:
libxul.so: undefined symbol: _ZNSbItN4base20string16_char_traitsESaItEE4_Rep20_S_empty_rep_storageE
Couldn't load XPCOM.

これは、使用しているlinuxのライブラリが何か足りない、もしくは古いって事でしょうか?
firefox-19で様子が変わるかと思っていたのですが、firefox-19でも同じ症状でした。

_________________
Mozilla/5.0 (X11; Linux i686; rv:17.0) Gecko/20100101 Firefox/17.0


通報する
ページトップ
 プロフィール  
引用付きで返信する  
投稿記事Posted: 2013年2月20日(水) 13:13 
オフライン
Moderator

登録日時: 2011年4月06日(水) 10:16
記事: 1098
お住まい: Tokyo
参考まで。

Linuxにて、Firefox 18以降で起動できないという(未確認)バグが登録されています。
Bug 829604 - Couldn't load XPCOM

_________________
[Desktop] Windows 7 Professional (32bit/SP1) / Geforce GTX 660Ti 2GB (340.43) / 4GB RAM
Mozilla/5.0 (Windows NT 6.1; rv:21.0) Gecko/20130219 Firefox/21.0

通報する
ページトップ
 プロフィール  
引用付きで返信する  
投稿記事Posted: 2013年2月25日(月) 16:11 
オフライン

登録日時: 2012年4月29日(日) 19:03
記事: 3
ヤンキース さんが書きました:
XPCOMGlueLoad error for file firefox-18.0/libxpcom.so:
libxul.so: undefined symbol: _ZNSbItN4base20string16_char_traitsESaItEE4_Rep20_S_empty_rep_storageE
Couldn't load XPCOM.

これは、使用しているlinuxのライブラリが何か足りない、もしくは古いって事でしょうか?
firefox-19で様子が変わるかと思っていたのですが、firefox-19でも同じ症状でした。


Linuxをお使いとのことですが、ディストリ(ex:Ubuntu,Fedora,Arch...)とそのバージョンはいくつでしょうか?
一応、確認をしておこうと思います。ちなみに当方にて Ubuntu 12.04/12.10,Fedora 18上のFirefox 18.0,19.0 は
正常な起動を確認しました。

_________________
Mozilla/5.0 (X11; Linux x86_64; rv:19.0) Gecko/20100101 Firefox/19.0


通報する
ページトップ
 プロフィール  
引用付きで返信する  
投稿記事Posted: 2013年2月25日(月) 20:27 
オフライン

登録日時: 2013年1月31日(木) 15:34
記事: 3
palさん、catback1059さん、有難うございました。

catback1059さん
使用してる
ディストリはかなり昔の物で自分で手を加えて使っているため、最近のディストリ
と比べると内容は全然違うと思います。
ですので、ライブラリが足りない、古いという可能性がかなりあると思いたずねてみました。

palさんの教えてくれたバグのサイトをみると同じ内容で起動できない人もいるようなので、
mozilla 側で変更してくれるのを
淡い期待で待ってみます。

_________________
Mozilla/5.0 (X11; Linux i686; rv:17.0) Gecko/20100101 Firefox/17.0


通報する
ページトップ
 プロフィール  
引用付きで返信する  
投稿記事Posted: 2013年2月25日(月) 21:40 
オフライン
Moderator

登録日時: 2011年4月06日(水) 10:16
記事: 1098
お住まい: Tokyo
ヤンキース さんが書きました:
使用してるディストリはかなり昔の物で自分で手を加えて使っているため、最近のディストリ
と比べると内容は全然違うと思います。
ですので、ライブラリが足りない、古いという可能性がかなりあると思いたずねてみました。
(略)
mozilla 側で変更してくれるのを淡い期待で待ってみます。

あらゆるソフトに共通する事項ですが、ソフトが新しくなっていけば、古い環境は捨てられていくのが運命です。
Win 95然り、Win98然り・・・
古いOSでは新しいものは使えません。

したがって、今後Mozilla側が(古い環境に)対応していく可能性はゼロに等しいでしょう。

新しいソフトを使いたいのであれば、それに合わせて環境も更新(刷新)しなければいけません。

_________________
[Desktop] Windows 7 Professional (32bit/SP1) / Geforce GTX 660Ti 2GB (340.43) / 4GB RAM
Mozilla/5.0 (Windows NT 6.1; rv:22.0) Gecko/20130224 Firefox/22.0

通報する
ページトップ
 プロフィール  
引用付きで返信する  
投稿記事Posted: 2013年2月26日(火) 01:26 
オフライン
Administrator

登録日時: 2005年6月23日(木) 23:29
記事: 2203
お住まい: 東京
Firefox 17, 18, 19 において、Linux で必要とされるライブラリやパッケージの要件は変わっていません。システム要件 を満たしているかもう一度確認を。

当該バグを見る限りでは、問題が起きているのは 3 人だけで開発者サイドでは再現できていない (UNCONFIRMED) ようですので、Firefox 側ではなくユーザのシステム側の問題と思われます (Firefox 側の問題ならもっと大騒ぎになってるはず)。
comment 12 では xulrunnner を別途インストールすることで解決したという報告もあるようです。

現状ではバグとして認識されていませんので、いくら待っても Mozilla が対処することはありません。

_________________
[Desktop] Windows 7 Professional SP 1 (64bit) / Intel Core i7-2600 / AMD Radeon HD 7870 / 16 GB Memory
[Laptop] Windows 7 Professional SP 1 (64bit) / Intel Core i5-520M vPro / Intel HD Graphics / 8 GB Memory
常用環境: Firefox Beta, Thunderbird Beta + Lightning Beta
テスト環境: Firefox ESR, Firefox Release, Firefox Aurora, Firefox Nightly (Win32, Win64 x86-64)

Cai/1.0 (Homo sapiens; N; Homo sapiens chemist; male; rv:0.0.3.1+)
-- いつまでたっても nightly
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20100101 Firefox/20.0

通報する
ページトップ
 プロフィール  
引用付きで返信する  
投稿記事Posted: 2013年3月02日(土) 21:47 
オフライン

登録日時: 2013年1月31日(木) 15:34
記事: 3
お騒がせしました。自己解決いたしました。

当初は検索しても該当する内容がヒットしなかったのですが、最近では海外サイトで数件ヒットするようになり、
その中に、GLIBCのバージョンが2。10。0以下だとこの問題が発生するとの書きこみがありました。

この症状でGLIBCって本当かな?と疑問に思ったのですが、GLIBCのバージョンを更進したところ無事起動できました。

_________________
Mozilla/5.0 (X11; Linux i686; rv:19.0) Gecko/20100101 Firefox/19.0


通報する
ページトップ
 プロフィール  
引用付きで返信する  
期間内表示:  ソート  
新しいトピックを投稿する このトピックは閉鎖されているため、編集・返信することはできません  [ 7 件の記事 ] 

All times are UTC + 9 hours


オンラインデータ

このフォーラムを閲覧中のユーザー: なし & ゲスト[1人]


トピック投稿:  可
返信投稿:  可
記事編集: 不可
記事削除: 不可
ファイル添付: 不可

検索:
ページ移動:  
Powered by MozillaZine.jp® Forum Software © phpBB Group , Almsamim WYSIWYG
Japanese translation principally by ocean