― MozillaZine.jp フォーラムは Mozilla 製品に関する情報交換の場です ―



All times are UTC + 9 hours

新しいトピックを投稿する トピックへ返信する  [ 3 件の記事 ] 
作成者 メッセージ
投稿記事Posted: 2015年8月12日(水) 16:32 
オフライン

登録日時: 2015年8月12日(水) 07:06
記事: 2
windows10にアップグレードしてからもweblioを使用できていたのですが、
今朝、PCを起動したところ、ツールバーからweblioのアイコンが消えてしまいました。
それで、アドオンweblioPaneを再インストールしてみましたが、「w」のアイコンがツールバーに表示されません。
どのような対処が必要でしょうか、お教え願います。

_________________
Mozilla/5.0 (Windows NT 10.0; WOW64; rv:40.0) Gecko/20100101 Firefox/40.0


通報する
ページトップ
 プロフィール  
引用付きで返信する  
投稿記事Posted: 2015年8月14日(金) 20:02 
※質問するときは、「フォーラムの利用に関するご案内」、とりわけ「質問するときは」に目を通し、OS の種類や Firefox のバージョンといった使用環境についての最低限の情報を書き添えることをお勧めします。

少し時間が経っていますが......。

weblioPane というアドオンは使ったことがなかったのですが、当方の環境(Windows 8 Pro 64bit)にある Firefox 40.0.2 と 38.2.0 に入れてみました。

38.2.0 では、ナビゲーションツールバーに weblioPane の [W] アイコンが表示され、Web ページ上の文字列を選択するとWeblio の辞書・翻訳のポップアップパネルが開きましたが、40.0.x ではアイコンが表示されず、機能としても動作しませんでした。
中間の 39.0.x はどうかわかりませんが、少なくとも 40.0.x では weblioPane は正常に働いていないように見えます。

現時点で weblioPane の最新バージョンは 1.1.1.1 ですが、このリリース日は 2013 年 7 月 19 日となっていて、2 年以上メンテナンスされていないようです。
2013 年 7 月時点での Firefox のバージョンは 22.0 ですから、現在の 40.0 とはかなり隔たりがあり、Firefox が仕様変更された部分も相応に存在します。

weblioPane のソースコードなどは見ていませんが(見ても理解できませんが...)、おそらく weblioPane が 40.0 に対応できていない可能性が高いと考えられます。

この場合、対策としては2つの方向性が考えられます。
(1)weblioPane が Firefox 40.0 に対応するのを待つ。あるいは作者にリクエストを出す。
(2)Firefox を現役 ESR 版である 38.x 系に乗り換える。【注】

【注】
Firefox をダウングレードする際、現在使っているプロファイルをそのまま使い回すと、予期しない問題が起こりやすくなります。
プロファイル内のファイル構成や仕様が変更されていることがあるので、新旧のバージョンで同一のプロファイルを行き来するような使い方をすると、新旧のファイル構成が混在するなどして、思わぬ不具合を誘発してしまうことがあるからです。
順当にバージョンを上げていく分には、原則的に旧仕様が正しく引き継がれるようになっていますが、その逆は保証されていません。
したがって、ダウングレードした Firefox を安定して動作させたいなら、それ用の新しいプロファイルを作り、現行プロファイルからブックマークなど必要最小限のデータだけを移行して、あとはアドオンもいちから入れ直したほうがいいと思います。
ESR 版もいずれはバージョンアップされます。そのときにまでにアドオンが対応していればいいのですが......。

(補足)
基本的に、Firefox のバージョンアップに対し、アドオン側が追従するのが本筋です。
そのため、Firefox の正式版がリリースされる前に開発版が提供されており、アドオンの動作をいろいろテストすることができます。そして、現状のままで正常に動作することが確認できたらそのまま、問題があれば修正が施された新バージョンのアドオンが公開され、Firefox の正式版リリース時点ではアドオンが正常に動作するようになっている、というのが理想です。
しかしながら、アドオン作者の様ざまな事情により、これが実行できないケースがあります。そうすると、Firefox の前バージョンでは正常に働いていたアドオンが、新バージョンではまったく使えなくなる、ということが起こりえます。

とりあえず以上です。役に立たない話だったらすみません。

_________________
Mozilla/5.0 (Windows NT 6.2; WOW64; rv:40.0) Gecko/20100101 Firefox/40.0


通報する
ページトップ
  
引用付きで返信する  
投稿記事Posted: 2015年8月17日(月) 06:43 
オフライン

登録日時: 2015年8月12日(水) 07:06
記事: 2
ありがとうございました。firfoxが自動的に40.0にバージョンアップされたせいであることが確認できました。

_________________
Mozilla/5.0 (Windows NT 10.0; WOW64; rv:40.0) Gecko/20100101 Firefox/40.0


通報する
ページトップ
 プロフィール  
引用付きで返信する  
期間内表示:  ソート  
新しいトピックを投稿する トピックへ返信する  [ 3 件の記事 ] 

All times are UTC + 9 hours


オンラインデータ

このフォーラムを閲覧中のユーザー: なし & ゲスト[1人]


トピック投稿:  可
返信投稿:  可
記事編集: 不可
記事削除: 不可
ファイル添付: 不可

検索:
ページ移動:  
Powered by MozillaZine.jp® Forum Software © phpBB Group , Almsamim WYSIWYG
Japanese translation principally by ocean